【UE4游戏开发】安装UE4时报SU-PQR1603错误的解决方法

  马三在开发过程中一直用的都是UE4.9版本(很久没有更新了。),因为功能都够用,所以也懒得去更新。这不最近UE4 发布了最新的4.14版本,本来想尝个鲜,试试新版的UE引擎怎么样,结果这一安装上就一直在报SU-PQR1603的错误,去UE4官网找了解决方案,按照上面的步骤操作也没有奏效。后来终于在UE4论坛一个不起眼的帖子的一层发现了解决方案,因此特地记录一下,以备不时之需。

  先上一下帖子的原始地址:https://answers.unrealengine.com/questions/344645/error-r-1603.html? 

  首先请确定你已经安装了vs2015和DirectX运行库之后还会报这个错误。下图就是奏效的解决方案:

  

  总结一下就是以下几步:

  1.确认安装各种必须的组件以及运行库。

  2.右键Epic Games Launcher的快捷方式,选择属性,然后在“目标”这一栏的后面加上-SkipBuildPatchPrereq,记得要用空格将其和原来的内容分隔开。

  3.重新以管理员身份运行Epic Games Launcher,并继续UE引擎的安装,这次就不会再出现报错的情况了。

  4.将Epic Games Launcher快捷方式的目标值复位成原来的内容(即删掉-SkipBuildPatchPrereq

  新版UE4引擎更新成功!终于可以愉快地玩耍了~(。◕ˇ∀ˇ◕)

 

 

作者:马三小伙儿
出处:http://www.cnblogs.com/msxh/p/6131051.html 
请尊重别人的劳动成果,让分享成为一种美德,欢迎转载。另外,文章在表述和代码方面如有不妥之处,欢迎批评指正。留下你的脚印,欢迎评论!

posted @ 2016-12-04 16:18  马三小伙儿  阅读(14415)  评论(0编辑  收藏  举报