动态规划:HDU1059-Dividing(多重背包问题的二进制优化)

Dividing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8755    Accepted Submission(s): 2374


Problem Description
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. 
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
 

 

Input
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000. 

The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.
 

 

Output
For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''. 

Output a blank line after each test case.
 

 

Sample Input
1 0 1 2 0 0
1 0 0 0 1 1
0 0 0 0 0 0
 
Sample Output
Collection #1:
Can't be divided.
 
Collection #2:
Can be divided.
 
题意:把六件物品,按价值平分;

解题心得:
1、其实这就是要给多重背包的问题,但是按照普通的做法那肯定是会超时的。需要优化,也就是二进制优化。
2、先说说二进制优化,这个题的二进制优化,就是将一个数改成很多个二的倍数的的数的和(例如:100可以变成2+4+8+16+32+37,这个37是剩下的可以不做处理),然后将O(n)的复杂度优化成O(logn)的复杂度。不太明白二进制问题的可以去看看快速幂的算法(快速幂入门)。实现方法主要看代码


自己在做这个题的时候的代码
#include<bits/stdc++.h>
using namespace std;
const int maxn = 6e5;
bool dp[maxn];
typedef struct
{
    int va;
    int num;
} Res;
int main()
{
    int T = 1;
    Res res[10];
    for(int i=1; i<=6; i++)
        res[i].va = i;
    while(scanf("%d%d%d%d%d%d",&res[1].num,&res[2].num,&res[3].num,&res[4].num,&res[5].num,&res[6].num) != EOF)
    {
        memset(dp,0,sizeof(dp));
        dp[0] = true;
        int Return = 0,sum = 0;
        for(int i=1; i<=6; i++)
        {
            Return += res[i].num;//全是0跳出
            sum += res[i].va * res[i].num;
        }
        if(!Return)
            break;

        printf("Collection #%d:\n",T++);
        if(sum % 2)//单数直接排除
        {
            printf("Can't be divided.\n\n");
            continue;
        }

        sum /= 2;
        for(int i=1; i<=6; i++)
        {
            int cnt = 0;
            for(int k=1; k<=res[i].num; k*=2)//k每次乘以2
            {
                cnt = k*res[i].va;
                for(int j=sum; j>=cnt; j--)
                {
                    if(dp[j-cnt])
                        dp[j] = true;
                }
                res[i].num -= k;//减去二进制之后的就是剩下的
            }

            if(cnt)//当res[i].num != 0
            {
                cnt = res[i].va * res[i].num;//将二进制处理之后剩下的一起处理
                for(int j=sum; j>=cnt; j--)
                {
                    if(dp[j-cnt])
                        dp[j] = true;
                }
            }
        }

        if(dp[sum])
            printf("Can be divided.\n");
        else
            printf("Can't be divided.\n");
        printf("\n");
    }
}


大神的代码(这个更加的容易理解)

大概I的意思就是将多重背包看作完全背包或者0-1背包来进行优化(多重背包的实质就是0-1背包,都是一样一样的),优化部分主要就是0-1背包部分,注意在每次调用0-1背包的时候的参数传递


#include<iostream>
#include<cstring>
#include<cstdio>
#define MAXV 60010

using namespace std;

int d[MAXV],V;

void bag01(int c,int w)//01背包
{
    int i;
    for(i=V;i>=c;i--)
    {
        if(d[i]<d[i-c]+w)
        {
            d[i]=d[i-c]+w;
        }
    }
}

void bagall(int c,int w)//完全背包
{
    int i;
    for(i=c;i<=V;i++)
    {
        if(d[i]<d[i-c]+w)
        {
            d[i]=d[i-c]+w;
        }
    }
}

void multbag(int c,int w,int n)//多重背包
{
    if(c*n>=V)//当某一项的价值总和比需要求的价值综合还更大时可以看作完全背包问题
    {
        bagall(c,w);return ;
    }
    int k=1;
    while(k<=n)//不然就看做很多个0-1背包问题的总和
    {
        bag01(k*c,k*w);
        n=n-k;
        k=k*2;
    }
    bag01(n*c,n*w);
}

int main()
{
    int n[6],sumv,i,k=1;
    while(cin>>n[0]>>n[1]>>n[2]>>n[3]>>n[4]>>n[5],n[0]+n[1]+n[2]+n[3]+n[4]+n[5])
    {
        memset(d,0,sizeof(d));
        sumv=n[0]+n[1]*2+n[2]*3+n[3]*4+n[4]*5+n[5]*6;
        if(sumv%2==1)
        {
            printf("Collection #%d:\nCan't be divided.\n\n",k++);
            continue;
        }
        V=sumv/2;
        for(i=0;i<6;i++)
        {
            if(n[i]) multbag(i+1,i+1,n[i]);
        }
        if(V==d[V]) printf("Collection #%d:\nCan be divided.\n\n",k++);
        else printf("Collection #%d:\nCan't be divided.\n\n",k++);
    }
    return 0;
}





posted @ 2017-07-10 15:12  GoldenFingers  阅读(213)  评论(0编辑  收藏  举报