【zoj2314】Reactor Cooling 有上下界可行流

题目描述

The terrorist group leaded by a well known international terrorist Ben Bladen is buliding a nuclear reactor to produce plutonium for the nuclear bomb they are planning to create. Being the wicked computer genius of this group, you are responsible for developing the cooling system for the reactor.

The cooling system of the reactor consists of the number of pipes that special cooling liquid flows by. Pipes are connected at special points, called nodes, each pipe has the starting node and the end point. The liquid must flow by the pipe from its start point to its end point and not in the opposite direction.

Let the nodes be numbered from 1 to N. The cooling system must be designed so that the liquid is circulating by the pipes and the amount of the liquid coming to each node (in the unit of time) is equal to the amount of liquid leaving the node. That is, if we designate the amount of liquid going by the pipe from i-th node to j-th as fij, (put fij = 0 if there is no pipe from node i to node j), for each i the following condition must hold:

fi,1+fi,2+...+fi,N = f1,i+f2,i+...+fN,i

Each pipe has some finite capacity, therefore for each i and j connected by the pipe must be fij <= cij where cij is the capacity of the pipe. To provide sufficient cooling, the amount of the liquid flowing by the pipe going from i-th to j-th nodes must be at least lij, thus it must be fij >= lij.

Given cij and lij for all pipes, find the amount fij, satisfying the conditions specified above.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

输入

The first line of the input file contains the number N (1 <= N <= 200) - the number of nodes and and M - the number of pipes. The following M lines contain four integer number each - i, j, lij and cij each. There is at most one pipe connecting any two nodes and 0 <= lij <= cij <= 10^5 for all pipes. No pipe connects a node to itself. If there is a pipe from i-th node to j-th, there is no pipe from j-th node to i-th.

输出

On the first line of the output file print YES if there is the way to carry out reactor cooling and NO if there is none. In the first case M integers must follow, k-th number being the amount of liquid flowing by the k-th pipe. Pipes are numbered as they are given in the input file.

样例输入

2

4 6
1 2 1 2
2 3 1 2
3 4 1 2
4 1 1 2
1 3 1 2
4 2 1 2

4 6
1 2 1 3
2 3 1 3
3 4 1 3
4 1 1 3
1 3 1 3
4 2 1 3

样例输出

NO

YES
1
2
3
2
1
1


题目大意

给你一张n个点和m条边的图,每条边有[li,ri]的容量,求是否有可行流?有则输出一组方案。

题解

有上下界网络流无源汇可行流模板题,题意都很直白。

转化为最大流。

假设有一条容量为[l,r]的路径连通x->y,那么进行如下操作:

1.记录路径的l(求总流量时会用到)

2.加入x->y,容量为r-l的边

3.将x的流入总数in[x]减去l,将y的流入总数in[y]加上l。

处理完所有路径后,再建立超级源点和超级汇点,并扫一遍每个点。

对于点x,如果in[x]>0,则加S->x,容量为in[x]的边,否则加x->T,容量为-in[x]的边。

跑一遍最大流,如果满流则有解,否则无解。

有解时,对于每条通道i,它的总流量为下界low[i]加上新图的流出量val[i<<1|1]。

#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
queue<int> q;
int head[210] , to[100000] , val[100000] , next[100000] , cnt , low[100000] , in[210] , dis[100000] , s , t;
void add(int x , int y , int z)
{
	to[++cnt] = y;
	val[cnt] = z;
	next[cnt] = head[x];
	head[x] = cnt;
}
bool bfs()
{
	int x , i;
	while(!q.empty()) q.pop();
	memset(dis , 0 , sizeof(dis));
	dis[s] = 1;
	q.push(s);
	while(!q.empty())
	{
		x = q.front();
		q.pop();
		for(i = head[x] ; i ; i = next[i])
		{
			if(val[i] && !dis[to[i]])
			{
				dis[to[i]] = dis[x] + 1;
				if(to[i] == t) return 1;
				q.push(to[i]);
			}
		}
	}
	return 0;
}
int dinic(int x , int l)
{
	if(x == t) return l;
	int temp = l , k , i;
	for(i = head[x] ; i ; i = next[i])
	{
		if(val[i] && dis[to[i]] == dis[x] + 1)
		{
			k = dinic(to[i] , min(temp , val[i]));
			if(!k) dis[to[i]] = 0;
			val[i] -= k , val[i ^ 1] += k;
			if(!(temp -= k)) break;
		}
	}
	return l - temp;
}
int main()
{
	int T;
	scanf("%d" , &T);
	while(T -- )
	{
		int n , m , i , x , y , z , sum = 0 , maxflow = 0;
		scanf("%d%d" , &n , &m);
		memset(head , 0 , sizeof(head));
		memset(in , 0 , sizeof(in));
		cnt = 1;
		s = 0 , t = n + 1;
		for(i = 1 ; i <= m ; i ++ )
		{
			scanf("%d%d%d%d" , &x , &y , &low[i] , &z);
			in[x] -= low[i] , in[y] += low[i];
			add(x , y , z - low[i]) , add(y , x , 0);
		}
		for(i = 1 ; i <= n ; i ++ )
		{
			if(in[i] > 0) sum += in[i] , add(s , i , in[i]) , add(i , s , 0);
			else if(in[i] < 0) add(i , t , -in[i]) , add(t , i , 0);
		}
		while(bfs()) maxflow += dinic(s , 0x7fffffff);
		if(maxflow != sum) printf("NO\n");
		else
		{
			printf("YES\n");
			for(i = 1 ; i <= m ; i ++ )
				printf("%d\n" , val[i << 1 | 1] + low[i]);
		}
		printf("\n");
	}
	return 0;
}

 

posted @ 2017-03-07 20:25  GXZlegend  阅读(254)  评论(0编辑  收藏  举报