【bzoj3943】[Usaco2015 Feb]SuperBull 最小生成树

题目描述

Bessie and her friends are playing hoofball in the annual Superbull championship, and Farmer John isin charge of making the tournament as exciting as possible. A total of N (1 <= N <= 2000) teams areplaying in the Superbull. Each team is assigned a distinct integer team ID in the range 1...2^30-1 to distinguish it from the other teams. The Superbull is an elimination tournament -- after every game, Farmer John chooses which team to eliminate from the Superbull, and the eliminated team can no longer play in any more games. The Superbull ends when only one team remains.Farmer John notices a very unusual property about the scores in matches! In any game, the combined score of the two teams always ends up being the bitwise exclusive OR (XOR) of the two team IDs. For example, if teams 12 and 20 were to play, then 24 points would be scored in that game, since 01100 XOR 10100 = 11000.Farmer John believes that the more points are scored in a game, the more exciting the game is. Because of this, he wants to choose a series of games to be played such that the total number of points scored in the Superbull is maximized. Please help Farmer John organize the matches.贝西和她的朋友们在参加一年一度的“犇”(足)球锦标赛。FJ的任务是让这场锦标赛尽可能地好看。一共有N支球队参加这场比赛,每支球队都有一个特有的取值在1-230-1之间的整数编号(即:所有球队编号各不相同)。“犇”锦标赛是一个淘汰赛制的比赛——每场比赛过后,FJ选择一支球队淘汰,淘汰了的球队将不能再参加比赛。锦标赛在只有一支球队留下的时候就结束了。FJ发现了一个神奇的规律:在任意一场比赛中,这场比赛的得分是参加比赛两队的编号的异或(Xor)值。例如:编号为12的队伍和编号为20的队伍之间的比赛的得分是24分,因为 12(01100) Xor 20(10100) = 24(11000)。FJ相信比赛的得分越高,比赛就越好看,因此,他希望安排一个比赛顺序,使得所有比赛的得分和最高。请帮助FJ决定比赛的顺序

输入

The first line contains the single integer N. The following N lines contain the N team IDs.第一行包含一个整数N接下来的N行包含N个整数,第i个整数代表第i支队伍的编号, 1<=N<=2000

输出

Output the maximum possible number of points that can be scored in the Superbull.一行,一个整数,表示锦标赛的所有比赛的得分的最大值

样例输入

4
3
6
9
10

样例输出

37


题解

由于n只有2000,可以建图然后最大生成树。

有趣的是kruskal都能过

#include <cstdio>
#include <algorithm>
using namespace std;
struct data
{
    int x , y , z;
}e[4000001];
int num[2001] , cnt , f[2001];
bool cmp(data a , data b)
{
    return a.z > b.z;
}
int find(int x)
{
    return x == f[x] ? x : f[x] = find(f[x]);
}
int main()
{
    int n , i , j , k = 0;
    long long ans = 0;
    scanf("%d" , &n);
    for(i = 0 ; i < n ; i ++ )
        scanf("%d" , &num[i]);
    for(i = 0 ; i < n ; i ++ )
    {
        f[i] = i;
        for(j = 0 ; j < n ; j ++ )
        {
            e[cnt].x = i;
            e[cnt].y = j;
            e[cnt].z = num[i] ^ num[j];
            cnt ++ ;
        }
    }
    sort(e , e + cnt , cmp);
    for(i = 0 ; i < cnt && k < n - 1 ; i ++ )
    {
        int tx = find(e[i].x) , ty = find(e[i].y);
        if(tx != ty)
        {
            k ++ ;
            ans += (long long)e[i].z;
            f[tx] = ty;
        }
    }
    printf("%lld\n" , ans);
    return 0;
}
posted @ 2017-01-09 16:55  GXZlegend  阅读(367)  评论(0编辑  收藏  举报