求知若饥,虚心若愚

Cisco交换机配置VLAN

 Cisco IOS中有两种方式创建vlan,在全局模式下使用vlan vlanid命令,如switch(config)#vlan 10; 在vlan database 下创建vlan ,如 switch(vlan)#vlan 20;

 

 

交换机配置:

 

Switch>enable

Switch#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Switch(config)#vlan 10

Switch(config-vlan)#name Math

Switch(config-vlan)#exit

Switch(config)#exit

Switch#

%SYS-5-CONFIG_I: Configured from console by console

 

Switch#vlan database

% Warning: It is recommended to configure VLAN from config mode,

  as VLAN database mode is being deprecated. Please consult user

  documentation for configuring VTP/VLAN in config mode.

 

Switch(vlan)#vlan 20 name Chinese

VLAN 20 added:

    Name: Chinese

Switch(vlan)#vlan 30 name Other

VLAN 30 added:

    Name: Other

Switch(vlan)#exit

APPLY completed.

Exiting....

Switch#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Switch(config)#interface fastEthernet 0/1

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access vlan 10

Switch(config-if)#exit

Switch(config)#interface fastEthernet 0/2

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access vlan 10

Switch(config-if)#exit

 

Switch(config)#interface range fastEthernet 0/3-6

Switch(config-if-range)#switchport mode access

Switch(config-if-range)#switchport access vlan 20

Switch(config-if-range)#exit

 

Switch(config)#interface range fastEthernet 0/7-9

Switch(config-if-range)#switchport mode access

Switch(config-if-range)#switchport access vlan 30

Switch(config-if-range)#exit

Switch(config)#exit

Switch#

%SYS-5-CONFIG_I: Configured from console by console

 

Switch#show vlan

 

VLAN Name                             Status    Ports

---- -------------------------------- --------- -------------------------------

1    default                          active    Fa0/10, Fa0/11, Fa0/12, Fa0/13

                                                Fa0/14, Fa0/15, Fa0/16, Fa0/17

                                                Fa0/18, Fa0/19, Fa0/20, Fa0/21

                                                Fa0/22, Fa0/23, Fa0/24

10   Math                             active    Fa0/1, Fa0/2

20   Chinese                          active    Fa0/3, Fa0/4, Fa0/5, Fa0/6

30   Other                            active    Fa0/7, Fa0/8, Fa0/9

1002 fddi-default                     act/unsup

1003 token-ring-default               act/unsup

1004 fddinet-default                  act/unsup

1005 trnet-default                    act/unsup

 

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2

---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

1    enet  100001     1500  -      -      -        -    -        0      0

10   enet  100010     1500  -      -      -        -    -        0      0

20   enet  100020     1500  -      -      -        -    -        0      0

30   enet  100030     1500  -      -      -        -    -        0      0

1002 fddi  101002     1500  -      -      -        -    -        0      0  

1003 tr    101003     1500  -      -      -        -    -        0      0  

1004 fdnet 101004     1500  -      -      -        ieee -        0      0  

1005 trnet 101005     1500  -      -      -        ibm  -        0      0  

 

Remote SPAN VLANs

------------------------------------------------------------------------------

 

 

Primary Secondary Type              Ports

------- --------- ----------------- ------------------------------------------

Switch#

//为VLAN配置ip地址(就是默认网关)

Switch(config)#interface vlan 10

Switch(config-if)#

%LINK-5-CHANGED: Interface Vlan10, changed state to up

 

Switch(config-if)#ip address 192.168.1.1 255.255.255.0

Switch(config-if)#no shutdown

Switch(config-if)#exit

 

Switch(config)#interface vlan 20

Switch(config-if)#

%LINK-5-CHANGED: Interface Vlan20, changed state to up

 

Switch(config-if)#ip address 192.168.2.1 255.255.255.0

Switch(config-if)#no shutdown

Switch(config-if)#exit

 

Switch(config)#interface vlan 30

Switch(config-if)#

%LINK-5-CHANGED: Interface Vlan30, changed state to up

 

Switch(config-if)#ip address 192.168.3.1 255.255.255.0

Switch(config-if)#no shutdown

Switch(config-if)#exit

 

PC设置:

 

 

 

 

 

互ping截图:

posted @ 2014-03-15 00:52 初行 阅读(...) 评论(...) 编辑 收藏