随笔分类 -  数据库

sqlserver2008里创建系统管理员
摘要:sql2008如何使用被禁止的"xp_cmdshell"前提是知道sa的连接密码,而且服务器能连接1433,不然啥都别说.C:\>DIRC:\SQLServer阻止了对组件''xp_cmdshell''的过程''sys.xp_cmdshell''的访问,因为此组件已作为此服务器安全配置的一部分而被关闭。系统管理员可以通过使用sp_configure启用''xp_cmdshell''。有关启用''xp_cmdshell''的详细信息,请参阅SQ 阅读全文

posted @ 2012-05-08 07:46 zqonline 阅读(1312) 评论(0) 推荐(0)

System.Data.SQLite 不能在.net 4.0 里引用的解决方法
摘要:两个程序集,由于http://sqlite.phxsoftware.com/的System.Data.SQLite是混合模式程序集,是针对“v2.0.50727”版的运行时生成的,在没有配置其他信息的情况下,无法在 4.0 运行时中加载该程序集。故需要在App.config中配置如下参数。<?xml version="1.0" encoding="utf-8" ?><configuration><startup useLegacyV2RuntimeActivationPolicy="true">&l 阅读全文

posted @ 2011-08-24 12:22 zqonline 阅读(2497) 评论(0) 推荐(0)

我电脑上的mssql2000居然,被黑了,在还原数据时提示:无法装载DLL Microsoft提示请误随意操作SQL数据库,以免对数据库造成不必要的麻烦或DLL所引用的某一DLL。原因:126(找不到指定模块)
摘要:无法装载DLL Microsoft提示请误随意操作SQL数据库,以免对数据库造成不必要的麻烦或DLL所引用的某一DLL。原因:126(找不到指定模块)处理方法检查看一下:master数据库的扩展存储过程,是否有最近修改的:第一步解决:sp_addextendedproc不可用use mastergocreate procedure sp_addextendedproc@functname nvarchar(517),@dllname varchar(255)asset implicit_transactions offif @@trancount > 0beginraiserror(15 阅读全文

posted @ 2011-04-20 16:12 zqonline 阅读(1850) 评论(0) 推荐(0)

解决SQL2000出现"无法执行查询,因为文件缺少或未注册。再次运行安装程序确保要求的文件已注册。"的方法
摘要:今天在写程序时,使用过企业管理器的过程中,打开表时,突然出现 "无法执行查询,因为文件缺少或未注册。再次运行安装程序确保要求的文件已注册。"的错误,重启后依然是这样。网上搜索了一下,都是认为,需要重新安装,SQL2000。但其中一位朋友说,只需要注册某些库,就可以了。此方法,我测试后有效。regsvr32 "C:\Program Files\Common Files\System\Ole DB\Oledb32.dll"regsvr32 "C:\Program Files\Common Files\System\Ado\Msado15.dll&q 阅读全文

posted @ 2011-04-11 19:10 zqonline 阅读(556) 评论(0) 推荐(0)

mysql中使用rand函数得到随机整数
摘要:得到1至50的mysql随机整数FLOOR(1 + (RAND() * 50)); 阅读全文

posted @ 2011-03-29 16:30 zqonline 阅读(31496) 评论(1) 推荐(0)

开启mysql远程访问的知识点
摘要:资料1:1、mysql默认是不允许远程连接的,因为有很大的安全隐患。。所以需要手动增加可以远程访问数据库的用户。下面是连接方式:# mysql -u root -p>;grant select,insert,update,delete on *.* toroot@"202.11.10.253" Identified by "dboomysql";----允许地址202.11.10.253上用... 阅读全文

posted @ 2010-09-02 18:03 zqonline 阅读(696) 评论(0) 推荐(0)

内部查询处理器错误: 查询处理器无法生成查询计划。有关详细信息,请与客户支持服务部门联系。
摘要:消息 8624,级别 16,状态 116,过程 p_PDM_0000001,第 61 行内部查询处理器错误: 查询处理器无法生成查询计划。有关详细信息,请与客户支持服务部门联系。消息 8624,级别 16,状态 116,过程 p_PDM_0000001,第 61 行内部查询处理器错误: 查询处理器无法生成查询计划。有关详细信息,请与客户支持服务部门联系。我的环境:sql2005相关资料:http:... 阅读全文

posted @ 2010-07-06 10:07 zqonline 阅读(3055) 评论(0) 推荐(0)

MySQL的转义字符“\”
摘要:\0一个ASCII 0 (NUL)字符。\n一个新行符。\t一个定位符。\r一个回车符。\b一个退格符。\'一个单引号(“'”)符。\ "一个双引号(“ "”)符。\\一个反斜线(“\”)符。\%一个“%”符。它用于在正文中搜索“%”的文字实例,否则这里“%&rdqu... 阅读全文

posted @ 2010-03-11 09:31 zqonline 阅读(2191) 评论(0) 推荐(0)

如何实现项目脚本的批量生成
摘要:需求:  一个大的信息管理系统是由各个单独的子系统组成的,有某些时候,只需要一部份的模块。这样在发布数据库的时候,就存在有比较大的问题。  只有两种方式:      1。不管客户需不需要,把整个数据库给他。      2。查找相应的表,存储过程,视图,函数。(如果没有记录,基本上是不可完成的工作,你愿意花大量的时间除外。)就算是你有记录,也得花不少时间。解决思路:  在维护一个数据对象表的同时,能... 阅读全文

posted @ 2009-12-08 17:12 zqonline 阅读(608) 评论(0) 推荐(0)

mysql与mssql连接字符串的区别。
摘要:以前用SQL Server 连接字符串是用“+”,现在数据库用mysql,写个累加两个字段值SQL语句居然不支持"+",郁闷了半天在网上查下,才知道mysql里的+是数字相加的操作,连接字符串是CONCAT函数例:mysql> select CONCAT('My', 'S', 'QL');-> 'MySQL' 阅读全文

posted @ 2009-10-14 18:03 zqonline 阅读(337) 评论(1) 推荐(0)

如何让Ado执行存储过程后能获取RecordCount的值。
摘要:Dim Cmd As New ADODB.Command Cmd.CommandText = Trim(procName) '//////引号内为存储过程 Cmd.CommandType = adCmdStoredProc Cmd.ActiveConnection = Conn Set rs1 = Cmd.Execute() '此操作,不能获取记录集的RecordCount的值,永远只能返回-1 ... 阅读全文

posted @ 2009-07-31 16:01 zqonline 阅读(467) 评论(0) 推荐(0)

SQLSERVER2005 建立链接服务器
摘要:SQLSERVER2005 建立链接服务器注意,产品名称就是链接服务器的名称! 阅读全文

posted @ 2009-07-06 11:11 zqonline 阅读(321) 评论(0) 推荐(0)

创建SQL作业错误的解决方法(不能将值 NULL 插入列 'owner_sid',表 'msdb.dbo.sysjobs';列不允许有空值。)
摘要:在用SQL语句创建SQL Server作业时有时出现如下错误:消息515,级别16,状态2,过程sp_add_job,第137行不能将值NULL插入列'owner_sid',表'msdb.dbo.sysjobs';列不允许有空值。INSERT失败。语句已终止。这可能与为作业创建的数据库登录ID有关,这个登录ID需要是数据库的所有者(我的是sa),因此将@owner_login_name=N'HYS... 阅读全文

posted @ 2009-07-06 11:09 zqonline 阅读(6500) 评论(1) 推荐(1)

比较通用的ID,ParentID结构表,返回树路径。
摘要:[代码] 阅读全文

posted @ 2009-04-21 17:16 zqonline 阅读(836) 评论(0) 推荐(0)

分拆列值
摘要:分拆列值 原著:邹建 改编:爱新觉罗.毓华(十八年风雨,守得冰山雪莲花开) 2007-12-16 广东深圳 有表tb, 如下: id value ----------- ----------- 1 aa,bb 2 aaa,bbb,ccc 欲按id,分拆value列, 分拆后结果如下: id value ----------... 阅读全文

posted @ 2009-03-09 16:40 zqonline 阅读(218) 评论(0) 推荐(0)

MySql中Group By和Order By使用的注意事项!
摘要:MySql中Group By和Order By使用方式和MsSql有一点小区别 Group By 完全一样,如: select zw as title,count(*) as id from jzxx group by zw 此语句能成功执行,但是加 Order by时注意,要在Order by排序的聚合函数上加 ``,如果有良好的编程习惯这个问题就不会出现了!在MsSql里都加上[],在My... 阅读全文

posted @ 2008-12-24 13:45 zqonline 阅读(2466) 评论(0) 推荐(0)

mysql 连接字符串与SQL不同
摘要:以前用SQL Server 连接字符串是用“+”,现在数据库用mysql,写个累加两个字段值SQL语句居然不支持"+",郁闷了半天在网上查下,才知道mysql里的+是数字相加的操作,连接字符串是CONCAT函数例:mysql> select CONCAT('My', 'S', 'QL');-> 'MySQL' http://www.cnblogs.com/lmjob/archive/... 阅读全文

posted @ 2008-11-13 17:56 zqonline 阅读(1282) 评论(0) 推荐(0)

MySql中的事务问题
摘要:今天非常开心,因为终于将昨天一个让我很郁闷的问题解决了。事情是这样的,根据业务逻辑的要求,需要对两张数据表进行更新,为了保证数据的完整性,就需要使用transaction的概念了。如以下代码所示:conn.setAutoCommit(false);try { PreparedStatement insertStatement = conn.prepareStatement("INSERT I... 阅读全文

posted @ 2008-11-13 17:50 zqonline 阅读(624) 评论(0) 推荐(0)

MySQL 4.1迁移到MySQL 5.0版本的中文乱码问题解决
摘要:系统开过过程中,将数据库由MySQL 4.1转化到MySQL 5.0,在升级过程中遇到了中文乱码问题。先描述一下两边的服务器版本和环境。原:Linux,mysql-standard-4.1.8-pc-linux-i686新:Windows Server 2003,MySQL 5.0.45-community本机客户端有两个:MySQL AB\MySQL Connector/ODBC 3.51 = ... 阅读全文

posted @ 2008-11-13 09:35 zqonline 阅读(756) 评论(0) 推荐(0)

Hibernate+mysql 中文问题解决方案.
摘要:1, mysql安装时设置字符集utf-8, jdbc驱动3.0.15以上. 2. hibernate配置文件中,加上属性 true UTF-8 3. web.xml设置Filter ================================================= Set Web Application Character Encoding cn.com... 阅读全文

posted @ 2008-11-13 09:33 zqonline 阅读(382) 评论(0) 推荐(0)

导航