Cisco交换机端口聚合(EtherChannel)

 

 

 

  端口聚合,英文简称EtherChannel(以太通道)是由Cisco研发的,应用于交换机之间的多链路捆绑技术。它的基本原理是:

将两个设备间多条物理链路捆绑在一起组成一条逻辑链路,从而达到带宽倍增的目的(这条逻辑链路带宽相当于物理链路带宽之和)。

除了增加带宽外,端口聚合还可以在多条链路上均衡分配流量,起到负载分担的作用;当一条或多条链路故障时,只要还有链路正常,

流量将转移到其它的链路上,整个过程在几毫秒内完成,从而起到冗余的作用,增强了网络的稳定性和安全性。两台交换机之间是否形

成EtherChannel也可以用协议自动协商。目前有两个协商协议:PAgP和LACP,PAgP(端口汇聚协议 Port Aggregation Protocol)

是Cisco私有的协议,而LACP(链路汇聚控制协议 Link Aggregation Control Protocol)是基于IEEE 802.3ad的国际标准,是一种实

现链路动态聚合的协议。

 

 

Switch(config-if-range)#channel-group 1 mode ?                   #通过此命令在交换机查看端口聚合可以使用的协议

  active   Enable LACP unconditionally                                       #主动发送LACP报文

  auto    Enable PAgP only if a PAgP device is detected               #被动发送PAgP报文

  desirable  Enable PAgP unconditionally                                   #主动发送PAgP报文

  on       Enable Etherchannel only                                           #手动设置,需要两边都设置成on

  passive  Enable LACP only if a LACP device is detected             #被动接收LACP报文

 

 

 

 

端口聚合说明:

1、Cisco最多允许EtherChannel绑定8个端口;

 (1)、如果是百兆网络,总带宽可达1.6Gbit/s;

 (2)、如果是千兆网络,总带宽可达16Gbit/s。

2、EtherChannel不支持10M端口;

3、EtherChannel编号只在本地有效,链路两端的编号可以不一样;

4、EtherChannel默认使用PAgP协议;

5、EtherChannel默认情况下是基于源MAC地址的负载平衡;

6、一个EtherChannel内所有的端口都必须具有相同的端口速率和双工模式,LACP只能是全双工模式;

7、channel-group接口会自动继承最小物理接口,或最先配置的接口模式;

8、cisco的交换机不仅可以支持第二层EtherChannel,还可以支持第三层EtherChannel。

 

 

 

 

 

实验环境:

标注:本教程只讲解端口聚合配置命令,其它配置请自行上网查阅资料。

 

 

两台Cisco思科交换 2960  + 一台Cisco思科交换机3560

思科3560交换机SW3配置思路:

1、  配置两个VLAN, VLAN 10分配给SW1交换机,VLAN 20分配给SW2交换机

2、  VLAN 10 配置IP地址 192.168.10.1 255.255.255.0 

   VLAN 20 配置IP地址:192.168.20.1 255.255.255.0

3、  开启HDCP功能及路由功能

4、  Fa0/23-24端口分配给SW1交换机做端口聚合,Fa0/21-22端口分配给SW2交换机做端口聚合

 

思科2960 交换机 SW1配置思路:

1、创建VLAN 10,并把fa0/1-2端口分配给VLAN 10

2、Fa0/23-24端口与上级交换机端口Fa0/23-24对应端口聚合

 

思科2960 交换机 SW1配置思路:

1、创建VLAN 20,并把fa0/1-2端口分配给VLAN 20

2、Fa0/23-24端口与上级交换机端口Fa0/21-22对应端口聚合

 

PC1电脑和PC2电脑分别设置共享文件,PC3电脑复制PC1电脑共享文件,PC4电脑复制PC2电脑共享文件,在同时复制过程中,可以查看复制的速度就可以看得出效果。

 

 

 

 

 

1、思科3560交换机SW3端口聚合配置:

 

#全局模式下进入Fa0/23-24端口

Switch(config)#interface range fastEthernet 0/23-24

#创建虚拟通道 channel-group 1 并设置模式为desirable

Switch(config-if-range)#channel-group 1 mode desirable

#描述channel-group 1虚拟通道从SW3连接SW1

Switch(config-if-range)#description  SW3-SW1

#强制虚拟通道 channel-group 1使用dot1q封装数据包

Switch(config-if-range)#switchport trunk encapsulation dot1q

#设置为trunk允许多个VLAN通过

Switch(config-if-range)#switchport mode trunk

#激活端口

Switch(config-if-range)#no shutdown

 

#全局模式下进入Fa0/21-22端口

Switch(config)#interface range fastEthernet 0/21-22

#创建虚拟通道 channel-group 2 并设置模式为desirable

Switch(config-if-range)#channel-group 2 mode desirable

#描述channel-group 2虚拟通道从SW3连接SW2

Switch(config-if-range)#description  SW3-SW2

#强制虚拟通道 channel-group 2使用dot1q封装数据包

Switch(config-if-range)#switchport trunk encapsulation dot1q

#设置为trunk允许多个VLAN通过
Switch(config-if-range)#switchport mode trunk

#激活端口

Switch(config-if-range)#no shutdown

 

标注:dot1q是802.1q标准,是vlan的一种封装方式,各类交换和路由使用的vlan通用协议模式。

 

 

 ===>>>希望对你所帮助,博主营养不良,当前页面右边点开打赏,你的支持是我无限的动力~!

 

2、思科 2960交换机SW1端口聚合配置:

 

#全局模式下进入fa0/23-24端口

Switch(config)#interface range fastEthernet 0/23-24

#创建虚拟通道 channel-group 1并设置模式为desirable

Switch(config-if-range)#channel-group 1 mode desirable

#描述channel-group 1虚拟通道从SW1连接SW3

Switch(config-if-range)#description  SW1-SW3

#设置为trunk允许多个VLAN通过

Switch(config-if-range)#switchport mode trunk

#指定允许通过channel-group 1的vlan,这里设置all是所有vlan,思科交换机默认是all

#如果设置只允许VLAN 10通过channel-group 1虚拟通道命令 switchport trunk allowed vlan 10

Switch(config-if-range)#switchport trunk allowed vlan all

#激活端口

Switch(config-if-range)#no shutdown

 

 

 

 

3、思科 2960交换机SW2端口聚合配置:

 

#全局模式下进入fa0/23-24端口

Switch(config)#interface range fastEthernet 0/23-24

#创建虚拟通道 channel-group 2并设置模式为desirable

Switch(config-if-range)#channel-group 2 mode desirable

#描述channel-group 2虚拟通道从SW2连接SW3

Switch(config-if-range)#description  SW2-SW3

#设置为trunk允许多个VLAN通过

Switch(config-if-range)#switchport mode trunk

#指定允许通过channel-group 2的vlan,这里设置all是所有vlan,思科交换机默认是all

Switch(config-if-range)#switchport trunk allowed vlan all

#激活端口

Switch(config-if-range)#no shutdown

 

 

 

 

4、端口聚合查看命令

 

#查看端口聚合信息,正常情况Port-channel显示是SU,如果显示SD就不正常

Switch#show etherchannel summary

1 Po1(SU) PAgP Fa0/23(P) Fa0/24(P)

2 Po2(SU) PAgP Fa0/21(P) Fa0/22(P)

#查看虚拟通道包含的接口

Switch#show etherchannel port-channel

#查看通道接口状况

Switch#show etherchannel load-balance

 

 

 

 

 

 

 

感谢三忆三哭博客提供参考:http://blog.sina.com.cn/s/blog_635e1a9e01017msv.html

 

posted @ 2017-04-01 09:30  邹龙彬  阅读(70224)  评论(0编辑  收藏