Hdu5115 Dire Wolf

Dire Wolf

Time Limit: 5000/5000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 3067    Accepted Submission(s): 1813

Problem Description
Dire wolves, also known as Dark wolves, are extraordinarily large and powerful wolves. Many, if not all, Dire Wolves appear to originate from Draenor.
Dire wolves look like normal wolves, but these creatures are of nearly twice the size. These powerful beasts, 8 - 9 feet long and weighing 600 - 800 pounds, are the most well-known orc mounts. As tall as a man, these great wolves have long tusked jaws that look like they could snap an iron bar. They have burning red eyes. Dire wolves are mottled gray or black in color. Dire wolves thrive in the northern regions of Kalimdor and in Mulgore.
Dire wolves are efficient pack hunters that kill anything they catch. They prefer to attack in packs, surrounding and flanking a foe when they can.
— Wowpedia, Your wiki guide to the World of Warcra
Matt, an adventurer from the Eastern Kingdoms, meets a pack of dire wolves. There are N wolves standing in a row (numbered with 1 to N from left to right). Matt has to defeat all of them to survive.
Once Matt defeats a dire wolf, he will take some damage which is equal to the wolf’s current attack. As gregarious beasts, each dire wolf i can increase its adjacent wolves’ attack by bi. Thus, each dire wolf i’s current attack consists of two parts, its basic attack ai and the extra attack provided by the current adjacent wolves. The increase of attack is temporary. Once a wolf is defeated, its adjacent wolves will no longer get extra attack from it. However, these two wolves (if exist) will become adjacent to each other now.
For example, suppose there are 3 dire wolves standing in a row, whose basic attacks ai are (3, 5, 7), respectively. The extra attacks bi they can provide are (8, 2, 0). Thus, the current attacks of them are (5, 13, 9). If Matt defeats the second wolf first, he will get 13 points of damage and the alive wolves’ current attacks become (3, 15).
As an alert and resourceful adventurer, Matt can decide the order of the dire wolves he defeats. Therefore, he wants to know the least damage he has to take to defeat all the wolves.
Input
The first line contains only one integer T , which indicates the number of test cases. For each test case, the first line contains only one integer N (2 ≤ N ≤ 200).
The second line contains N integers ai (0 ≤ ai ≤ 100000), denoting the basic attack of each dire wolf.
The third line contains N integers bi (0 ≤ bi ≤ 50000), denoting the extra attack each dire wolf can provide.
Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), y is the least damage Matt needs to take.
Sample Input
2 3 3 5 7 8 2 0 10 1 3 5 7 9 2 4 6 8 10 9 4 1 2 1 2 1 4 5 1
Sample Output
Case #1: 17 Case #2: 74
Hint
In the first sample, Matt defeats the dire wolves from left to right. He takes 5 + 5 + 7 = 17 points of damage which is the least damage he has to take.
题目大意:(英语阅读题......)每只狼有攻击力和给相邻的狼增加的攻击力.杀死一只狼会受到这只狼本身的攻击力和相邻的狼给这只狼增加的攻击力的伤害,求杀死这些狼受到的最小的伤害.
分析:和poj1651还是挺像的,只不过poj1651要求两个端点不能动,这道题中两个端点的狼必须被杀死.
   定义状态:f[i][j]表示位置i到位置j的狼被杀死的最小代价.枚举最后一个被杀死的狼k.此时k收到第i-1和第j+1只狼给它增加的攻击力,杀死它的代价为a[k] + b[i - 1] + b[j + 1],根据代价转移就好了.最后答案是f[1][n].
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

const int inf = 0x7ffffff;

int T,n,a[210],b[210],f[210][210],cas;

int main()
{
    scanf("%d",&T);
    while (T--)
    {
        scanf("%d",&n);
        for (int i = 1; i <= n; i++)
            scanf("%d",&a[i]);
        for (int i = 1; i <= n; i++)
            scanf("%d",&b[i]);
        for (int len = 1; len <= n; len++)
        {
            for(int i = 1; i + len - 1 <= n; i++)
            {
                int j = i + len - 1;
                if (len == 1)
                    f[i][j] = a[i] + b[i - 1] + b[j + 1];
                else
                {
                    f[i][j] = inf;
                    for (int k = i; k <= j; k++)
                        f[i][j] = min(f[i][j],f[i][k - 1] + f[k + 1][j] + b[i - 1] + b[j + 1] + a[k]);
                }
            }
        }
        printf("Case #%d: %d\n",++cas,f[1][n]);
    }

    return 0;
}

 

posted @ 2018-02-20 16:13  zbtrs  阅读(187)  评论(0编辑  收藏  举报