poj1651 Multiplication Puzzle

Multiplication Puzzle
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 11593   Accepted: 7179

Description

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row. 

The goal is to take cards in such order as to minimize the total number of scored points. 

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring 
10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be 
1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

Output

Output must contain a single integer - the minimal score.

Sample Input

6
10 1 50 50 20 5

Sample Output

3650
题目大意:每次选一个数删掉,贡献是这个数左边的数*这个数本身*这个数右边的数.端点的两个数不能删掉,最小价值.
分析:区间dp.令f[i][j]表示区间[i,j],i和j是最后保留的两个数,这个区间的最小价值.那么枚举最后一个删除的数k,删掉数k的贡献就是:a[i] * a[k] * a[j],保留下k的贡献是:f[i][k] + f[k][j].状态转移方程就特别明显了.
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

int n,a[110],f[110][110];

int main()
{
    scanf("%d",&n);
    for (int i = 1; i <= n; i++)
        scanf("%d",&a[i]);
    memset(f,127/3,sizeof(f));
    for (int l = 1; l <= n; l++)
    {
        for (int i = 1; i + l - 1 <= n; i++)
        {
            int j = i + l - 1;
            if(l <= 2)
                f[i][j] = 0;
            else
            {
                for (int k = i + 1; k < j; k++)
                    f[i][j] = min(f[i][j],f[i][k] + f[k][j] + a[i] * a[k] * a[j]);
            }
        }
    }
    printf("%d\n",f[1][n]);

    return 0;
}

 

 
posted @ 2018-02-20 15:06  zbtrs  阅读(172)  评论(0编辑  收藏  举报