floyd 求最小环 poj 1734

Sightseeing trip
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 3649   Accepted: 1400   Special Judge

Description

There is a travel agency in Adelton town on Zanzibar island. It has decided to offer its clients, besides many other attractions, sightseeing the town. To earn as much as possible from this attraction, the agency has accepted a shrewd decision: it is necessary to find the shortest route which begins and ends at the same place. Your task is to write a program which finds such a route.

In the town there are N crossing points numbered from 1 to N and M two-way roads numbered from 1 to M. Two crossing points can be connected by multiple roads, but no road connects a crossing point with itself. Each sightseeing route is a sequence of road numbers y_1, ..., y_k, k>2. The road y_i (1<=i<=k-1) connects crossing points x_i and x_{i+1}, the road y_k connects crossing points x_k and x_1. All the numbers x_1,...,x_k should be different.The length of the sightseeing route is the sum of the lengths of all roads on the sightseeing route, i.e. L(y_1)+L(y_2)+...+L(y_k) where L(y_i) is the length of the road y_i (1<=i<=k). Your program has to find such a sightseeing route, the length of which is minimal, or to specify that it is not possible,because there is no sightseeing route in the town.

Input

The first line of input contains two positive integers: the number of crossing points N<=100 and the number of roads M<=10000. Each of the next M lines describes one road. It contains 3 positive integers: the number of its first crossing point, the number of the second one, and the length of the road (a positive integer less than 500).

Output

There is only one line in output. It contains either a string 'No solution.' in case there isn't any sightseeing route, or it contains the numbers of all crossing points on the shortest sightseeing route in the order how to pass them (i.e. the numbers x_1 to x_k from our definition of a sightseeing route), separated by single spaces. If there are multiple sightseeing routes of the minimal length, you can output any one of them.

Sample Input

5 7
1 4 1
1 3 300
3 1 10
1 2 16
2 3 100
2 5 15
5 3 20

Sample Output

1 3 5 2


该题题意就是求图中的最小环。
将floyd算法优化即可,即将floyd在运算的过程中,添加几步即可。
要注意的是,如果图为有向图,则其中两点成环的情况要考虑,而如果为无向图,则不要考虑两个点的情况。


代码实现:
#include<iostream>
#include<stdio.h>
#define max 100000000
using namespace std;
int a[105][105];
int d[105][105];
int pre[105][105];
int p[105];
int main(){
    int n,m;
    while(cin>>n>>m){
       for(int i=0;i<=n;i++){
               for(int j=0;j<=n;j++){
                       a[i][j]=max;
                       d[i][j]=max;
                       pre[i][j]=j;
                       }
                       }
       for(int i=1;i<=m;i++){
               int temp1,temp2,temp3;
               scanf("%d%d%d",&temp1,&temp2,&temp3);
               //cin>>temp1>>temp2>>temp3;
              if(a[temp1][temp2]>temp3){
               a[temp1][temp2]=temp3;
               a[temp2][temp1]=temp3;
               d[temp1][temp2]=temp3;
               d[temp2][temp1]=temp3;
               }
               }
       int minn=max;
       int times=0;
       for(int k=1;k<=n;k++){
               for(int i=1;i<k;i++){
                       for(int j=1;j<i;j++){
                               if(i!=j&&d[i][j]!=max&&a[j][k]!=max&&a[k][i]!=max&&d[i][j]+a[i][k]+a[k][j]<minn){     //if is dir, delete i!=j
                                          minn=d[i][j]+a[i][k]+a[k][j];
                                          times=0;
                                          int v=i;
                                          p[times++]=v;
                                          while(pre[v][j]!=j){
                                               p[times++]=pre[v][j];
                                               v=pre[v][j];
                                          }
                                          p[times++]=j;
                                          p[times++]=k;
                                          }
                                          }
                                          }
               for(int g=1;g<=n;g++){
                       for(int j=1;j<=n;j++){
                               if(d[g][k]!=max&&d[k][j]!=max&&d[g][k]+d[k][j]<d[g][j]){
                                          d[g][j]=d[g][k]+d[k][j];
                                          pre[g][j]=pre[g][k];
                                          }
                                          }
                                          }
            }
       if(minn==max){
           cout<<"No solution."<<endl;
           continue;
           }
     //  else
       //    cout<<minn<<endl;
       for(int g=0;g<times;g++){
               cout<<p[g];
               if(g<times-1)
                    cout<<" ";
               }
       cout<<endl;
       }
    return 0;
} 

 

posted on 2012-09-27 22:36  yumao  阅读(368)  评论(0编辑  收藏  举报

导航