教你一步步composer安装Magento2.3

  以前外贸建站一直用zencart,这段时间ytkah比较有时间,就决定用magento来创建一下站点。magento不像普通的程序一样下载就可以直接安装,需要借助composer安装,还没没composer环境的朋友可以参考composer安装其实可以很简单 两行命令就解决了。magento对php要求比较高一些,建议使用php7.1,不然会提示环境不支持。(本机测试环境:centos6.8/ mysql/ apache)注意这些文件夹generated,/app/etc,/pub/media,/pub/static权限设为可写入。还有如果是网站目录打开了防跨站攻击(open_basedir),安装的时候记得先关闭。

This package requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 but your PHP version (7.2.5) does not satisfy that requirement.

  php还要开启一些扩展,否则也会提示错误,比如ext-xsl等

    - The requested PHP extension ext-mcrypt * is missing from your system. Install or enable PHP's mcrypt extension.
    - The requested PHP extension ext-xsl * is missing from your system. Install or enable PHP's xsl extension.

  还有不能禁用一些函数比如syslog,openlog,exec,system,syformlink,proc_open函数,否则会提示错误。我们现在开始安装

  进入站点目录,

cd /www/wwwroot/www.z5w.net

删除原有的.user.ini,index.html,404.html,特别是.user.ini一定要删除,因为magento有个配置文件要覆盖它。  

然后composer install

composer install

  然后会下载很多的组件

  等下载完了就可以开始正式进入安装了

  进入网址www.z5w.net/setup,按步骤进行

  1.环境检测

  

  2.配置数据库连接

  3.网站设置,支持https加密

  4.个性化设置

  5.设置管理员账号密码

  6.程序安装

安装成功

  安装完成后,记得将/app/etc的写入权限禁用

posted @ 2018-05-30 17:20  ytkah  阅读(1194)  评论(0编辑  收藏  举报
网址导航 gg N / G Sitemap

部分内容来源于网络,如有版权问题请联系删除

T0P
导航