poj2524-Ubiquitous Religions

C - Ubiquitous Religions

Time Limit: 5000 MS Memory Limit: 65536 KB

64-bit integer IO format: %I64d , %I64u Java class name: Main

Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in. 

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

Sample Input

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output

Case 1: 1
Case 2: 7

Hint

Huge input, scanf is recommended.
 
并查集模板题简单变新,前边这种是完全没有优化的,所以时间巨长!!      错了4发,PE,这个—_—!
//3469 ms 544 KB C++ 1295 B
#include <cstdio>
using namespace std;
const int maxn = 50005;
int father[maxn];
int mark[maxn];

void init(int n)
{
    for(int i = 1; i <= n; ++i)
    {
        father[i] = i;
        mark[i] = 0;
    }
}

int serch(int x)
{
    if(father[x] == x)
        return x;
    return father[x] = serch(father[x]);
}

void join(int x, int y)
{
    int fx = serch(x), fy = serch(y);
    if(fx != fy)
        father[fx] = fy;
}

int main()
{
    int n, m, a, b;
    int casee = 0;
    while(scanf("%d %d", &n, &m)!= EOF && (n || m))
    {
        casee++;
        init(n);
        for(int i = 1; i <= m; ++i)
        {
            scanf("%d %d", &a, &b);
            join(a, b);
        }

        int res = 0;
        for(int i = 1; i <= n; ++i)
        {
            if(!mark[i])
            {
                mark[i] = 5;
                for(int j = 1; j <= n; ++j)
                {
                    if(!mark[j] && (serch(i) == serch(j)))
                    {
                        mark[j] = 1;
                    }
                }
            }
        }

        for(int i = 1; i <= n; ++i)
        {
            if(mark[i] == 5)
                res++;
        }

        printf("Case %d: %d\n", casee, res);
    }
    return 0;
}

  

 采用路径压缩后能快点,路径压缩只需改一句话。当然还有其他优化,还在学习中。。。
 
///Accepted	3469 ms	544 KB	C++	1295 B	
int serch(int x)
{
    if(father[x] == x)
        return x;
    return father[x] = serch(father[x]);   ///以前为 return  serch(father[x]); 
}

  

posted @ 2014-07-21 22:06  unicoe  阅读(198)  评论(0编辑  收藏  举报