安装 openmpi 4.0 用于 horovod 编译

最近编译 horovod框架过程中,需要使用openmpi 4.0但是环境中的openmpi版本比较低,所以在手动安装openmpi4.0 用于编译,下面对过程进行简要记录,进行备忘:

  • curl -O -L https://download.open-mpi.org/release/open-mpi/v4.0/openmpi-4.0.1.tar.gz
  • tar xvzf openmpi-4.0.1.tar.gz 
  • ./configure --prefix=/usr/local (--prefix 用于配置自身环境中安装的位置) 
  • make all; make install;
  • 配置环境变量,指向安装的位置即可;export PATH=路径:$PATH;

保持更新,转载请注明出处 cnblogs.com/xuyaowen; 如果您编译过程中遇到什么难以解决的问题,欢迎留言交流;

posted @ 2019-11-15 21:37  xuyaowen  阅读(...)  评论(... 编辑 收藏