PAT1002. A+B for Polynomials

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

 

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2

水题,设一个数组存就好了,注意不要记录相加为0的项(主要失分点)
#include<stdio.h>
int main()
{
    int num,a,arrayNum[1001];
    float b,Aarray[1001]; 
    for(int i=0;i<=1000;i++)
    {
        arrayNum[i]=0;
        Aarray[i]=0;
    }
    while(scanf("%d",&num)!=EOF)
    {    
        
        for(int i=0;i<num;i++)
        {
            scanf("%d %f",&a,&b);
            arrayNum[a]+=1;
            Aarray[a]+=b;
            //printf("%d:%d %.1f\n",a,arrayNum[a],Aarray[a]);
        }        
    }
        int sum=0;
    for(int i=0;i<=1000;i++)
    {
        if(Aarray[i]!=0)
        {
            sum+=1;
        }
    }
    printf("%d",sum);
    for(int i=1000;i>=0;i--)
    {
        if(arrayNum[i]!=0)
        {
            if(Aarray[i]!=0)
            printf(" %d %.1f",i,Aarray[i]);
        }
    }
}

 

posted on 2018-04-30 14:02  USTH_XD  阅读(117)  评论(0编辑  收藏  举报

导航