POJ 3660 Cow Contest(传递闭包)

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ NA ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M(1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2

题意:给出n只奶牛,m个胜负关系,求有几只奶牛的排名可以确定?

题解:传递闭包什么的,听着很高级,其实非常滑稽,感觉自学啥的也就两分钟,其实也就是一个floyd的延伸
用floyd根据三头牛之间a-b,b-c的胜负关系来判断a-c的胜负关系,然后显然除了和自己以外,如果和其他奶牛的关系已经确定了,他的排名也就确定了
然后就写出来了

代码如下:
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;

int map[110][110],n,m;

int main()
{
    memset(map,-1,sizeof(map));
    scanf("%d%d",&n,&m);
    int xx,yy;
    for(int i=1;i<=m;i++)
    {
        scanf("%d%d",&xx,&yy);
        map[xx][yy]=1;
        map[yy][xx]=0;
    }
    for(int i=1;i<=n;i++)
    {
        map[i][i]=2;
    }
    for(int k=1;k<=n;k++)
    {
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                if(map[i][k]==1&&map[k][j]==1)
                {
                    map[i][j]=1;
                }
                if(!map[i][k]&&!map[k][j])
                {
                    map[i][j]=0;
                }
            }
        }
    }
    int ans=0;
    for(int i=1;i<=n;i++)
    {
        int flag=1;
        for(int j=1;j<=n;j++)
        {
            if(map[i][j]==-1)
            {
                flag=0;
            }
        }
        ans+=flag;
    }
    printf("%d\n",ans);
}

 




posted @ 2018-07-14 16:34  Styx-ferryman  阅读(143)  评论(0编辑  收藏  举报