poj2151 Check the difficulty of problems(概率dp)

Description

Organizing a programming contest is not an easy job. To avoid making the problems too difficult, the organizer usually expect the contest result satisfy the following two terms: 
1. All of the teams solve at least one problem. 
2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems. 

Now the organizer has studied out the contest problems, and through the result of preliminary contest, the organizer can estimate the probability that a certain team can successfully solve a certain problem. 

Given the number of contest problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also assume that team i solves problem j with the probability Pij (1 <= i <= T, 1<= j <= M). Well, can you calculate the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems? 

Input

The input consists of several test cases. The first line of each test case contains three integers M (0 < M <= 30), T (1 < T <= 1000) and N (0 < N <= M). Each of the following T lines contains M floating-point numbers in the range of [0,1]. In these T lines, the j-th number in the i-th line is just Pij. A test case of M = T = N = 0 indicates the end of input, and should not be processed.

Output

For each test case, please output the answer in a separate line. The result should be rounded to three digits after the decimal point.

Sample Input

2 2 2
0.9 0.9
1 0.9
0 0 0

Sample Output

0.972
题意:有m场比赛,t个队伍,告诉你每个队伍每场比赛的胜率,求所有队伍获胜一场以上且冠军队伍获胜n场及以上的概率
题解:万事开头难,先解释一下数据
2 2 2
0.9 0.9
1 0.9
化成题意就是求所有队伍获胜一场以上且冠军队伍获胜两场及以上的概率
首先是A队胜0场概率PA=(1-0.9)*(1-0.9)=0.01
B队胜0场概率PB(1-1)*(1-0.9)=0
AB队均胜一场概率PAB(1-0.9*0.9-0.1*0.1)*(1-0.9*1-0)=0.018
P=1-PA-PB-PAB=0.972

所以首先要保证所有队伍胜利场数均大于等于1
设其概率为P1
然后再保证所有队伍中至少有一个获胜大于等于n场
即减去均在1~n-1场的概率P2
即为正确解

推第i个队做出k道的概率可以用dp的思想
dp[i][j][k]=dp[i][j-1][k-1]*p[i][j]+dp[i][j-1][k]*(1-p[i][j]) (前者为做出了第j题后做出k道题的概率,后者为没做出第j题后做出k道题的概率)

唯一的注意点是
g++ 用f
c++ 用lf
2333
代码如下:
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;

int n,m,t;
double p[1010][50],dp[1010][50][50],s[1010][50];         //dp[i][j][k]表示队伍i在前j道题中解出k道的概率 s[i][j]表示i队做出题目数小于等于j道的概率 

int main()
{
    while(scanf("%d%d%d",&m,&t,&n)==3&&(n||m||t))
    {
        for(int i=1;i<=t;i++)
        {
            for(int j=1;j<=m;j++)
            {
                scanf("%lf",&p[i][j]);
            }
        }
        for(int i=1;i<=t;i++)
        {
            dp[i][0][0]=1;                                                                 
            for(int j=1;j<=m;j++)
            {
                dp[i][j][0]=dp[i][j-1][0]*(1-p[i][j]);
            }
            for(int j=1;j<=m;j++)
            {
                for(int k=1;k<=j;k++)
                {
                    dp[i][j][k]=dp[i][j-1][k-1]*p[i][j]+dp[i][j-1][k]*(1-p[i][j]);
                }
            }
            s[i][0]=dp[i][m][0];
            for(int j=1;j<=m;j++)
            {
                s[i][j]=s[i][j-1]+dp[i][m][j];
            }
        }
        double p1=1;
        double p2=1;
        for(int i=1;i<=t;i++)
        {
            p1*=(1-s[i][0]);
            p2*=(s[i][n-1]-s[i][0]);
        }
        printf("%.3lf\n",p1-p2);
    }
} 

 



















posted @ 2018-02-25 08:03  Styx-ferryman  阅读(255)  评论(0编辑  收藏  举报