POJ2318 TOYS(叉积判断点与直线的关系+二分)

Calculate the number of toys that land in each bin of a partitioned toy box. 
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys. 

John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box. 
 
For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

Hint

As the example illustrates, toys that fall on the boundary of the box are "in" the box.
题意:

给出一个矩形抽屉,然后有n个板子放在其中,连接上下底。给出m个玩具的坐标(视作点), 
问n+1个区间内,每个区间中有多少玩具。

思路:
首先给出的木板是从左往右排序过的,如果一个点在某个板子x左边,一定会在板子y>x 左边,所以满足单调性,二分。 
然后是判断点在直线左边,此处用的是向量p-l与向量u-l之间的关系,若叉乘值小于0,表示点p在直线l-u左边,反之则在右边。

详细请见:http://blog.csdn.net/u013557725/article/details/40146311

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
using namespace std;
struct point
{
    int x,y;
    point(){}
    point(int _x,int _y)
    {
        x=_x;y=_y;
    }
    point operator - (const point &b) const
    {
        return point(x-b.x,y-b.y);
    }
}u[5005],l[5005];
int n,m,x1,y1,x2,y2,ans[5005];
int cross(point a,point b)//计算叉乘 
{
    return a.x*b.y-b.x*a.y;
}
int main()
{
    while (scanf("%d",&n)!=EOF&&n!=0)
    {
        scanf("%d%d%d%d%d",&m,&x1,&y1,&x2,&y2);
        memset(ans,0,sizeof(ans));
        for (int i=0;i<n;i++)
        {
            int uu,ll;
            scanf("%d%d",&uu,&ll);
            u[i]=point(uu,y1);
            l[i]=point(ll,y2);//用point储存直线的端点 
        }
        for (int i=0;i<m;i++)
        {
            point p;
            scanf("%d%d",&p.x,&p.y);
            int le=0,ri=n,t=n;//因二分无法判断最右边的情况,所以t先赋值为n 
            while (le<=ri)
            {
                int mid=(le+ri)/2;
                if (cross(p-l[mid],u[mid]-l[mid])<=0)//叉乘小于0,p在直线ui-li左边,查找左区间,否则查找右区间 
                {
                    t=mid;  
                    ri=mid-1; 
                }
                else le=mid+1;
             } 
             ++ans[t];
        }
        for (int i=0;i<=n;i++)  
          {  
              printf("%d: %d\n",i,ans[i]);  
          }  
          printf("\n");  
    }
    return 0;
 } 

 

 

 

posted @ 2017-07-12 11:33  Styx-ferryman  阅读(290)  评论(0编辑  收藏  举报