【PAT】1041. Be Unique (20)

题目链接:http://pat.zju.edu.cn/contests/pat-a-practise/1041

题目描述:

 

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1, 104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on 5 31 5 88 67 88 17, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (<=105) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print "None" instead.

Sample Input 1:
7 5 31 5 88 67 88 17
Sample Output 1:
31
Sample Input 2:
5 888 666 666 888 888
Sample Output 2:
None

 

分析:(1)直接用查询表。(2)有个坑爹的陷阱,用cin输入会超时,但是用scanf输入去可以通过。原因是???

参考代码:


 

#include<iostream>
#include<cstdio>
#include<string.h>
using namespace std;
int result[10000 + 5];
int input[100000 + 5];
int main()
{
	int n;
	cin>>n;
	int i;
	int temp;
	bool flag = false;

	for(i=0; i<n; i++)
	{
		//cin>>input[i];   用cin会超时, 用scanf不会
		scanf("%d",&input[i]);
		result[ input[i] ]++;
	}

	for(i=0; i<n; i++)
	{
		if(result[ input[i] ] == 1)
		{
			flag = true;
			break;
		}
	}
	if(flag)
		cout<<input[i]<<endl;
	
	else
		cout<<"None"<<endl;
	return 0;
}


 

 

posted @ 2013-08-27 19:05  pangbangb  阅读(282)  评论(0编辑  收藏  举报