HDU 4642 (13.08.25)

Fliping game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 853    Accepted Submission(s): 612

Problem Description
Alice and Bob are playing a kind of special game on an N*M board (N rows, M columns). At the beginning, there are N*M coins in this board with one in each grid and every coin may be upward or downward freely. Then they take turns to choose a rectangle (x 1, y 1)-(n, m) (1 ≤ x 1≤n, 1≤y 1≤m) and flips all the coins (upward to downward, downward to upward) in it (i.e. flip all positions (x, y) where x 1≤x≤n, y 1≤y≤m)). The only restriction is that the top-left corner (i.e. (x 1, y 1)) must be changing from upward to downward. The game ends when all coins are downward, and the one who cannot play in his (her) turns loses the game. Here's the problem: Who will win the game if both use the best strategy? You can assume that Alice always goes first.
 

 

Input
The first line of the date is an integer T, which is the number of the text cases.
Then T cases follow, each case starts with two integers N and M indicate the size of the board. Then goes N line, each line with M integers shows the state of each coin, 1<=N,M<=100. 0 means that this coin is downward in the initial, 1 means that this coin is upward in the initial.
 

 

Output
For each case, output the winner’s name, either Alice or Bob.
 

 

Sample Input
2 2 2 1 1 1 1 3 3 0 0 0 0 0 0 0 0 0
 

 

Sample Output
Alice Bob


水题, 看最后一个数就行了, 是1, Alice赢, 是0, Bob赢~


AC代码:

 

#include<stdio.h>

int main() {
    int T;
    scanf("%d", &T);
    while(T--) {
        int r, c;
        scanf("%d %d", &r, &c);
        int key;
        for(int i = 0; i < r; i++)
            for(int j = 0; j < c; j++)
                scanf("%d", &key);
        if(key == 1)
            printf("Alice\n");
        else
            printf("Bob\n");
    }
    return 0;
}

 

 

 

posted @ 2013-08-26 19:11  pangbangb  阅读(304)  评论(0编辑  收藏  举报