Bzoj 3942: [Usaco2015 Feb]Censoring(kmp)

3942: [Usaco2015 Feb]Censoring
Description
Farmer John has purchased a subscription to Good Hooveskeeping magazine for his cows, so they have plenty of material to read while waiting around in the barn during milking sessions. Unfortunately, the latest issue contains a rather inappropriate article on how to cook the perfect steak, which FJ would rather his cows not see (clearly, the magazine is in need of better editorial oversight).
FJ has taken all of the text from the magazine to create the string S of length at most 10^6 characters. From this, he would like to remove occurrences of a substring T to censor the inappropriate content. To do this, Farmer John finds the first occurrence of T in S and deletes it. He then repeats the process again, deleting the first occurrence of T again, continuing until there are no more occurrences of T in S. Note that the deletion of one occurrence might create a new occurrence of T that didn’t exist before.
Please help FJ determine the final contents of S after censoring is complete
有一个S串和一个T串,长度均小于1,000,000,设当前串为U串,然后从前往后枚举S串一个字符一个字符往U串里添加,若U串后缀为T,则去掉这个后缀继续流程。
Input
The first line will contain S. The second line will contain T. The length of T will be at most that of S, and all characters of S and T will be lower-case alphabet characters (in the range a..z).
Output
The string S after all deletions are complete. It is guaranteed that S will not become empty during the deletion process.
Sample Input
whatthemomooofun
moo
Sample Output
whatthefun
HINT
Source
Silver

/*
kmp+栈模拟.
先将t串自匹配.
然后将s与t串匹配.
又是fail数组的套路题orz. 
*/
#include<cstring>
#include<cstdio>
#define MAXN 1000001
using namespace std;
int l1,l2,top,next[MAXN],fail[MAXN];
char s1[MAXN],s2[MAXN],ans[MAXN];
void slove()
{
    int p;
    for(int i=2;i<=l1;i++)
    {
        p=next[i-1];
        while(p&&s2[i]!=s2[p+1]) p=next[p];
        if(s2[i]==s2[p+1]) p++;
        next[i]=p;
    }
}
void kmp()
{
    int p;
    for(int i=1;i<=l1;i++)
    {
        ans[++top]=s1[i];
        p=fail[top-1];
        while(p&&ans[top]!=s2[p+1]) p=next[p];
        if(ans[top]==s2[p+1]) p++;
        fail[top]=p;
        if(p==l2) top-=l2;
    }
    for(int i=1;i<=top;i++) printf("%c",ans[i]);
}
int main()
{
    scanf("%s",s1+1);l1=strlen(s1+1);
    scanf("%s",s2+1);l2=strlen(s2+1);
    slove();kmp();
    return 0;
}
posted @ 2017-02-06 15:19  nancheng58  阅读(136)  评论(0编辑  收藏  举报