HDU 1021 Fibonacci Again

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 53310    Accepted Submission(s): 25205


Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 

 

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 

 

Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 

 

Sample Input
0 1 2 3 4 5
 

 

Sample Output
no no yes no no no

题解:数据太大,递归不行,进行预计算%3.

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

int main()
{
    int a[1000005];
    a[0] =7;a[1] =11;
    for(int i=2 ; i<1000005; i++){
        a[i] = a[i-1]%3+a[i-2]%3;
      }
    int n;
    while(cin>>n){
      if(a[n] %3 ==0 )
        printf("yes\n");
      else
      printf("no\n");

    }
 return 0;
}

  

 

 
 
posted @ 2016-09-25 21:04  lzyer  阅读(209)  评论(0编辑  收藏  举报