protobuf

因为老掉卡,只能从新装驱动,从新编译。

新装了好多东西。caffe2, detectron, pytorch。要不是因为tensorflow要用py3.0,我可能这个也装上了。。。。。

于是caffe编译protobuf有点问题了。捋了一遍才发现是protobuf版本问题。conda安装的是3.5.2,但是通过sudo apt-get install安装的是2.6.1。

解决办法就是,把两个版本都删掉,然后安装统一的版本。

安装protobuf从源文件开始安装,我是安装的3.5.2,从github下载源码,一步步编译安装的。conda自己的库里有3.5.2.

 

posted @ 2018-04-18 09:33  caoeryingzi  阅读(180)  评论(0编辑  收藏  举报