博客园 首页 私信博主 显示目录 隐藏目录 管理

E题 - A+B for Input-Output Practice (IV)

 
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
 

Description

Your task is to Calculate the sum of some integers. 
 

Input

Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed. 
 

Output

For each group of input integers you should output their sum in one line, and with one line of output for each line in input. 
 

Sample Input

4 1 2 3 4
5 1 2 3 4 5 
0
 

Sample Output

10 15
 
题解:输入求和的数字个数,然后输入数字求他们的和,比如4 1 2 3 4,有四个数字,分别为1 2 3 4,求他们的和,但是注意限制条件0!!
 
 
#include<stdio.h>
int main()
{
    int n,a;
   while(scanf("%d",&n)&&n)
   {
       int sum=0;
       for(int i=1;i<=n;i++)
     {
         scanf("%d",&a);
         sum=sum+a;
     }
      printf("%d\n",sum);
   }
    return 0;
}

 

posted @ 2015-10-15 19:01  hfcnal  阅读(1565)  评论(0编辑  收藏  举报