2019年3月26日

摘要: 运行npm run dev报错, webpack-dev-server --inline --progress --config build/webpack.dev.conf.js npm ERR! code ELIFECYCLEnpm ERR! errno 1npm ERR! vue_test@1 阅读全文
posted @ 2019-03-26 14:43 二婷啵 阅读(837) 评论(0) 推荐(0) 编辑
 
摘要: 前几天写的直接运行npm run dev还是ok的,突然不行了,前面报错是css-loader没有,删除style标签上的lang='scss'就好了,先不需要这个依赖。这个先不管。 只是后面的 run `npm audit fix` to fix them, or `npm audit` for 阅读全文
posted @ 2019-03-26 14:41 二婷啵 阅读(1070) 评论(0) 推荐(0) 编辑
 
摘要: 1.设置.vue模板 打开编辑器,点击文件 —— 首选项 —— 用户代码片段,会弹出来一个输入框。 在输入框输入vue,回车,会打开一个vue.json文件。 在里面复制以下代码: 模板内容可按自己的喜好自行修改。 然后新建一个.vue文件,输入vue然后按tab键。 2.如果第一步没有成功 如果第 阅读全文
posted @ 2019-03-26 14:09 二婷啵 阅读(3198) 评论(0) 推荐(0) 编辑
 

2018年9月25日

摘要: 在console.log()或console.debug()中输出时会有%d,%s等符号。 %s for a String value 字符类型 %d or %i for a Integer value 整型 %f for a Floating point number 浮点类型number %o 阅读全文
posted @ 2018-09-25 14:07 二婷啵 阅读(745) 评论(0) 推荐(0) 编辑
 

2018年8月14日

摘要: 如果你并没有接触过ES6,当你看到下面的代码时,肯定是有点懵逼的(这是什么鬼?心中一万头神兽奔腾而过),但是你没看错,这就是ES6。不管你看不看它,它都在这里。 1 2 3 4 5 6 7 8 9 10 var a = (msg) => () => msg; var bobo = { _name: 阅读全文
posted @ 2018-08-14 13:51 二婷啵 阅读(4085) 评论(0) 推荐(1) 编辑
 

2018年8月13日

摘要: 类似标题:jQuery选择什么版本?jquery一般用什么版本?jquery ie8兼容版本。jquery什么版本稳定? 目前jQuery有三个大版本:1.x:兼容ie678,使用最为广泛的,官方只做BUG维护,功能不再新增。因此一般项目来说,使用1.x版本就可以了,最终版本:1.12.4 (201 阅读全文
posted @ 2018-08-13 11:05 二婷啵 阅读(343) 评论(0) 推荐(0) 编辑
 
摘要: <script type="text/javascript" src="https://cdn.bootcss.com/jquery/3.2.1/jquery.js"></script> <script type="text/javascript" src="https://cdn.bootcss. 阅读全文
posted @ 2018-08-13 10:49 二婷啵 阅读(5816) 评论(0) 推荐(0) 编辑
 

2018年8月3日

摘要: websocket的两个属性:readyState和bufferedAmount。 根据readyState属性可以判断webSocket的连接状态,该属性的值可以是下面几种: 0 :对应常量CONNECTING (numeric value 0), 正在建立连接连接,还没有完成。The conne 阅读全文
posted @ 2018-08-03 11:42 二婷啵 阅读(5304) 评论(0) 推荐(0) 编辑
 

2018年7月12日

摘要: 一、安装 npm install vue-awesome-swiper 二、项目中引入 import 'swiper/dist/css/swiper.css'import {swiper,swiperSlide} from 'vue-awesome-swiper' 重要代码如图: 附上官方案例源码: 阅读全文
posted @ 2018-07-12 16:22 二婷啵 阅读(2284) 评论(0) 推荐(0) 编辑
 

2018年7月6日

摘要: 很多同学可能在写h5的时候,也会遇到移动端如何控制屏幕自适应问题!在移动端网页开发中,我们可以用手机淘宝的flexible.那么在vue当中,也同样可以用!接下来就介绍下如何在vue-cli配置的项目里来实现屏幕自适应一、首先,我们需要安装flexible库.项目目录下 cmd命令:npm inst 阅读全文
posted @ 2018-07-06 10:58 二婷啵 阅读(3278) 评论(0) 推荐(0) 编辑