protagonist

SOLDIERS

问题 b: SOLDIERS

时间限制: 1 Sec  内存限制: 128 MB
提交: 32  解决: 17
[提交] [状态] [讨论版] [命题人:admin]

题目描述

N soldiers of the land Gridland are randomly scattered around the country. 
A position in Gridland is given by a pair (x,y) of integer coordinates. Soldiers can move - in one move, one soldier can go one unit up, down, left or right (hence, he can change either his x or his y coordinate by 1 or -1). 
The soldiers want to get into a horizontal line next to each other (so that their final positions are (x,y), (x+1,y), ..., (x+N-1,y), for some x and y). Integers x and y, as well as the final order of soldiers along the horizontal line is arbitrary. 
The goal is to minimise the total number of moves of all the soldiers that takes them into such configuration. 
Two or more soldiers must never occupy the same position at the same time. 

 

输入

The first line of the input contains the integer N, 1 <= N <= 10000, the number of soldiers. 
The following N lines of the input contain initial positions of the soldiers : for each i, 1 <= i <= N, the (i+1)st line of the input file contains a pair of integers x[i] and y[i] separated by a single blank character, representing the coordinates of the ith soldier, -10000 <= x[i],y[i] <= 10000. 

 

输出

The first and the only line of the output should contain the minimum total number of moves that takes the soldiers into a horizontal line next to each other.
 

 

样例输入

5
1 2
2 2
1 3
3 -2
3 3

样例输出

8
思路:y坐标取中位数,x坐标转换为右值相等即可。
#include<bits/stdc++.h>
#include<vector>
using namespace std;
#define REP(i, a, b) for(int i = (a); i <= (b); ++ i)
#define REP(j, a, b) for(int j = (a); j <= (b); ++ j)
#define PER(i, a, b) for(int i = (a); i >= (b); -- i)
#define inf 1e50
template <class T>
inline void rd(T &ret){
    char c;
    ret = 0;
    while ((c = getchar()) < '0' || c > '9');
    while (c >= '0' && c <= '9'){
        ret = ret * 10 + (c - '0'), c = getchar();
    }
}
const int maxn=1e4+5;
int n,p[maxn],q[maxn];
long long ans;
int main(){
    rd(n);
    REP(i,1,n){
        cin>>p[i]>>q[i];
    }
    sort(p+1,p+n+1);
    sort(q+1,q+n+1);
    REP(i,1,n)p[i]-=i;
    sort(p+1,p+n+1);
    int a=p[n/2+1],b=q[n/2+1];
    REP(i,1,n){
        ans+=(abs(p[i]-a)+abs(q[i]-b));
    }
    cout<<ans<<endl;
}

 

posted @ 2019-02-11 16:44  czy-power  阅读(455)  评论(0编辑  收藏  举报