ET框架服务端部署到Linux--升级3.1

框架升级3.1参考:https://www.cnblogs.com/cj8988/p/14098017.html

 

安装.netcore 3.1

我的安装方法,直接下载文件(Centos7系统,之前安装过core2.2,卸载后通过命名安装3.1,出现各种问题)

问题:https://q.cnblogs.com/q/128970/

 

一:Centos7环境搭建

1、下载

去官网查找下载包:  https://dotnet.microsoft.com/download/dotnet-core/thank-you/sdk-3.1.404-linux-x64-binaries

wget https://download.visualstudio.microsoft.com/download/pr/ec187f12-929e-4aa7-8abc-2f52e147af1d/56b0dbb5da1c191bff2c271fcd6e6394/dotnet-sdk-3.1.404-linux-x64.tar.gz

 

2、解压

tar -zxf dotnet-sdk-3.1.404-linux-x64.tar.gz 

 

3、测试:

./dotnet --version

如果报错

[root@iZj6ca8athxvwbkta09dc8Z dotnet]# ./dotnet --version
Process terminated. Couldn't find a valid ICU package installed on the system. Set the configuration flag System.Globalization.Invariant to true if you want to run with no globalization support.

需要安装icu

 sudo yum install icu
再次运行

./dotnet --version

3.1.404

 

 

 

 

4、添加软连接

whereis dotnet

出现
dotnet:  /usr/local/dotnet

命令:

sudo ln -s /usr/local/dotnet/dotnet /usr/bin/dotnet

就可以在任何位置使用  dotnet --version

 

二、打包发布 -- 参考:https://www.cnblogs.com/cj8988/p/13968251.html  发布阶段

 

posted @ 2020-12-07 17:17  Foto_CShow  阅读(152)  评论(0编辑  收藏  举报