hdu 1711---KMP

题目链接

 

Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 
Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 
Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 
Sample Input
2
13  5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
 
Sample Output
6
-1
 
代码如下:
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
using namespace std;
int n[10005];
int s[1000005],a[10005];
int len1,len2;

void kmp()
{
    n[0]=0;
    for(int i=1,k=0;i<len2;i++)
    {
        while(k>0&&a[k]!=a[i]) k=n[k-1];
        if(a[k]==a[i]) k++;
        n[i]=k;
    }
}

int main()
{
    ///cout << "Hello world!" << endl;
    int T;
    cin>>T;
    while(T--)
    {
        scanf("%d%d",&len1,&len2);
        for(int i=0;i<len1;i++)
            scanf("%d",&s[i]);
        for(int i=0;i<len2;i++)
            scanf("%d",&a[i]);
        kmp();
        int flag=-1;
        for(int i=0,j=0;i<len1;i++)
        {
            while(j>0&&a[j]!=s[i]) j=n[j-1];
            if(a[j]==s[i]) j++;
            if(j==len2) { flag=i-len2+1; break; }
        }
        if(flag>=0) printf("%d\n",flag+1);
        else puts("-1");
    }
    return 0;
}

 

posted @ 2017-05-23 19:55  茶飘香~  阅读(290)  评论(0编辑  收藏  举报