KMP--Cyclic Nacklace

 题目网址:http://acm.hust.edu.cn/vjudge/contest/view.action?cid=110060#problem/D

Description

CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task. 

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2: 

Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden. 
CC is satisfied with his ideas and ask you for help.
 

Input

The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases. 
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000 ).
 

Output

For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.
 

Sample Input

3
aaa
abca
abcde
 

Sample Output

0
2
5
 
题意:输入一个字符串,在末尾或前端添加字符 ,使字符串首位连接后构成循环,字符串必须含有循环节,即至少含有2个循环节。
 
思路:在末尾或前端添加字符 ,使字符串首位连接后构成循环,仔细分析后发现在首尾添加字符的效果是一样的,故只在末尾添加。考虑字符串abcabcab的next[]数组值为0,0,0,1,2,3,4,5   next[7]=5为字符串尾部与前缀匹配的最大长度,s[0]=s[3],s[3]=s[6],s[0]=s[6],可以发现存在周期长为3,所以对于所有字符串min=len-next[len-1]为最小周期。
 
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
using namespace std;
char s[100005];
int  p[100005];

void next_(int len)
{
    int k=0;
    p[0]=0;
    for(int i=1;i<len;i++)
    {
        while(k>0&&s[k]!=s[i])
            k=p[k-1];
        if(s[k]==s[i])
            k++;
        p[i]=k;
    }
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%s",s);
        int len=strlen(s);
        next_(len);
        int minn=len-p[len-1];
        if(minn==len) printf("%d\n",len);
        else  printf("%d\n",(minn-len%minn)%minn);
    }
    return 0;
}

 

posted @ 2016-03-22 17:03  茶飘香~  阅读(144)  评论(0编辑  收藏  举报