完成作业的先后顺序

题目网址: http://acm.hust.edu.cn/vjudge/contest/view.action?cid=68966#problem/D

Description

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. 
Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject's name, each string will at most has 100 characters) and two integers D(the deadline of the subject), C(how many days will it take Ignatius to finish this subject's homework). 

Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier. 
 

Output

For each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one. 
 

Sample Input

2 3 Computer 3 3 English 20 1 Math 3 2 3 Computer 3 3 English 6 3 Math 6 3
 

Sample Output

2 Computer Math English 3 Computer English Math
 
解题思路: 本题中使用了二进制枚举,dp[i]表示i的二进制中所有1对应的作业按照顺序写所扣得分,t[]表示i的二进制中所有1所对应的作业按照顺序写所花的总时间(天数)。
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <stack>
using namespace std;
#define INF 0x3f3f3f3f
const int Max=(1<<15)+10;
char s[20][110];
int dp[Max],t[Max],pre[Max],dea[20],fin[20];

int main()
{
    int T,n;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        scanf("%s%d%d",s[i],&dea[i],&fin[i]);
        t[0]=0;
        memset(dp,INF,sizeof(dp));
        dp[0]=0;
        int bit=1<<n;
        for(int i=1;i<bit;i++)//二进制枚举
        for(int j=n-1;j>=0;j--)
        {
            int tmp=1<<j;
            if(!(i&tmp))
            continue;
            int score=t[i-tmp]-dea[j]+fin[j];  
            if(score<0) score=0;
            if(dp[i]>dp[i-tmp]+score)
            {
                dp[i]=dp[i-tmp]+score;
                t[i]=t[i-tmp]+fin[j];
                pre[i]=j;
            }
        }
        printf("%d\n",dp[bit-1]);
        stack<int> p;
        int m=bit-1;
        for(int i=0;i<n;i++)
        {
            p.push(pre[m]);
            m=m-(1<<pre[m]);
        }
        for(int i=0;i<n;i++)
        {
            printf("%s\n",s[p.top()]);
            p.pop();
        }
    }
    return 0;
}

 

 
 
 
 
posted @ 2016-03-11 21:56  茶飘香~  阅读(561)  评论(0编辑  收藏  举报