广搜(棋)

题目网址: http://acm.uestc.edu.cn/#/problem/show/1221

Ancient Go

Time Limit: 3000/1000MS (Java/Others)     Memory Limit: 65535/65535KB (Java/Others)
 

Yu Zhou likes to play Go with Su Lu. From the historical research, we found that there are much difference on the rules between ancient go and modern go.

Here is the rules for ancient go they were playing:

  • The game is played on a 8×8 cell board, the chess can be put on the intersection of the board lines, so there are 9×9 different positions to put the chess.
  • Yu Zhou always takes the black and Su Lu the white. They put the chess onto the game board alternately.
  • The chess of the same color makes connected components(connected by the board lines), for each of the components, if it's not connected with any of the empty cells, this component dies and will be removed from the game board.
  • When one of the player makes his move, check the opponent's components first. After removing the dead opponent's components, check with the player's components and remove the dead components.

One day, Yu Zhou was playing ancient go with Su Lu at home. It's Yu Zhou's move now. But they had to go for an emergency military action. Little Qiao looked at the game board and would like to know whether Yu Zhou has a move to kill at least one of Su Lu's chess.

Input

The first line of the input gives the number of test cases, T(1T100). T test cases follow. Test cases are separated by an empty line. Each test case consist of 9 lines represent the game board. Each line consists of 9 characters. Each character represents a cell on the game board. . represents an empty cell. x represents a cell with black chess which owned by Yu Zhou. o represents a cell with white chess which owned by Su Lu.

Output

For each test case, output one line containing Case #x: y, where x is the test case number (starting from 1) and y is Can kill in one move!!! if Yu Zhou has a move to kill at least one of Su Lu's components. Can not kill in one move!!! otherwise.

Sample input and output

Sample InputSample Output
2

.......xo
.........
.........
..x......
.xox....x
.o.o...xo
..o......
.....xxxo
....xooo.

......ox.
.......o.
...o.....
..o.o....
...o.....
.........
.......o.
...x.....
........o
Case #1: Can kill in one move!!!
Case #2: Can not kill in one move!!!

Hint

In the first test case, Yu Zhou has 4 different ways to kill Su Lu's component.

In the second test case, there is no way to kill Su Lu's component.

Source

The 2015 China Collegiate Programming Contest
 
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <cmath>
///http://acm.hust.edu.cn/vjudge/contest/view.action?cid=100505#problem/D
using namespace std;
char map[15][15];
bool vis[15][15];
int qx[100],qy[100];
int dir[4][2]= {{1,0},{-1,0},{0,1},{0,-1}};
int s1,s2;
int sum=0;

int bfs(int i,int j)
{
    int flag;
    flag=1;
    sum=0;
    int l=0,r=0;
    qx[r]=i;
    qy[r++]=j;
    vis[i][j]=1;
    while(l<r)
    {
        int curx=qx[l],cury=qy[l++];
        for(int t=0; t<4; t++)
        {
            int nx=curx+dir[t][0];
            int ny=cury+dir[t][1];
            if(sum>=1&&nx>=0&&nx<=8&&ny>=0&&ny<=8&&!vis[nx][ny]&&map[nx][ny]=='.')
            {
                flag=0;
                vis[s1][s2]=0;
            }
            if(nx>=0&&nx<=8&&ny>=0&&ny<=8&&!vis[nx][ny]&&map[nx][ny]=='o')
            {
                vis[nx][ny]=1;
                qx[r]=nx;
                qy[r++]=ny;
            }
            if(nx>=0&&nx<=8&&ny>=0&&ny<=8&&!vis[nx][ny]&&map[nx][ny]=='.')
            {
                if(flag)
                {
                    sum++;
                    s1=nx;
                    s2=ny;
                    vis[nx][ny]=1;
                }
            }
        }
    }
    if(flag)
    return 1;
    return 0;
}

int main()
{
    int T,ca=1;
    int i,j,f;
    cin>>T;
    while(T--)
    {
        f=0;
        for(i=0;i<9;i++)
        cin>>map[i];
        memset(vis,0,sizeof(vis));
        for(i=0;i<9;i++)
        for(j=0;j<9;j++)
        {
            if(map[i][j]=='o'&&!vis[i][j])
            {
                f=bfs(i,j);
                if(f) goto endw;
            }
        }
        endw:;
        if(f)
            printf("Case #%d: Can kill in one move!!!\n",ca++);
        else
            printf("Case #%d: Can not kill in one move!!!\n",ca++);
    }
    return 0;
}

 

posted @ 2015-12-07 18:51  茶飘香~  阅读(190)  评论(0编辑  收藏  举报