fibonacci数列的和取余(2)

Maybe ACMers of HIT are always fond of fibonacci numbers, because it is so beautiful. Don't you think so? At the same time,fishcanfly always likes to change and this time he thinks about the following series of numbers which you can guess is derived from the definition of fibonacci number.

The definition of fibonacci number is:

f(0) = 0, f(1) = 1, and for n>=2, f(n) = f(n - 1) + f(n - 2)

We define the new series of numbers as below:

f(0) = a, f(1) = b, and for n>=2, f(n) = p*f(n - 1) + q*f(n - 2),where p and q are integers.

Just like the last time, we are interested in the sum of this series from the s-th element to the e-th element, that is, to calculate .""""

Great!Let's go!

Input

The first line of the input file contains a single integer t (1 <= t <= 30), the number of test cases, followed by the input data for each test case.

Each test case contains 6 integers a,b,p,q,s,e as concerned above. We know that -1000 <= a,b <= 1000,-10 <= p,q <= 10 and 0 <= s <= e <= 2147483647.

Output

One line for each test case, containing a single interger denoting S MOD (10^7) in the range [0,10^7) and the leading zeros should not be printed.

Sample Input

2
0 1 1 -1 0 3
0 1 1 1 2 3

Sample Output

2
3

#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;
const long long mod=1e7;

typedef struct
{
  long long m[3][3];
}mat;

mat I={1,0,0,0,1,0,0,0,1};

mat calc(mat a,mat b)              //矩阵相乘计算
{
    int i,j,k;
    mat c;
    for(i=0;i<3;i++)
    for(j=0;j<3;j++)
    {
        c.m[i][j]=0;
       for(k=0;k<3;k++)
      {
        c.m[i][j]+=(a.m[i][k]*b.m[k][j]+mod)%mod;
      }
      c.m[i][j]=(c.m[i][j]+mod)%mod;
    }
    return c;
}

mat matirx(mat P,long long n)    //矩阵快速幂(二分法)
{
    mat m=P,b=I;
    while(n>=1)
    {
        if(n&1) b=calc(b,m);
        n>>=1;
        m=calc(m,m);
    }
    return b;
}

int main()
{
    int t,a,b,p,q;
    long long s,e,sum;
    cin>>t;
    while(t--)
    {
        sum=0;
        scanf("%d%d%d%d%lld%lld",&a,&b,&p,&q,&s,&e);
        mat x,y,P={p,q,0,1,0,0,1,0,1};      //p,q由输入决定,不能在全局定义mat P
        y=matirx(P,e);
        sum=(b*y.m[2][0]+a*y.m[2][1]+a*y.m[2][2])%mod;
        sum=(sum+mod)%mod;
        if(s>1)
        {
            x=matirx(P,s-1);
            sum=sum-(b*x.m[2][0]+a*x.m[2][1]+a*x.m[2][2])%mod;
            sum=(sum+mod)%mod;
        }
        else if(s==1)
           sum-=a;
        sum=(sum+mod)%mod;
        printf("%lld\n",sum);
    }
    return 0;
}

  

posted @ 2015-08-16 17:44  茶飘香~  阅读(340)  评论(0编辑  收藏  举报