error the @annotation pointcut expression is only supported at Java 5 compliance

今天碰到这个错误,在网上找了下,是因为aspectjweaver.jar用的是1.5.3 本地eclipse的jdk版本为1.7
下载高版本的aspectjweaver.jar会解决此问题
http://cn.jarfire.org/aspectjweaver.html

posted @ 2016-08-26 13:30  蟹丸  阅读(...)  评论(... 编辑 收藏