hdu4405--Aeroplane chess(概率dp第七弹:飞行棋游戏--2012年网络赛)

Aeroplane chess

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1628    Accepted Submission(s): 1103


Problem Description
Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are 1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N.

There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is no two or more flight lines start from the same grid.

Please help Hzz calculate the expected dice throwing times to finish the game.
 

Input
There are multiple test cases. 
Each test case contains several lines.
The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000).
Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N).  
The input end with N=0, M=0. 
 

Output
For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point.
 

Sample Input
2 0 8 3 2 4 4 5 7 8 0 0
 

Sample Output
1.1667 2.3441
 

Source


从0点走到n点。每一次掷筛子得x,向前走x步,有m条飞行通道,能够不算向前走,直接飞到。没有两个飞行线路从同一个点出发,问期望。

dp[i] = ∑(1/6*dp[i+j])+1 ;

对于飞行路线,由i到j的飞行路线,那么就意味着,当它到第i个位置的时候。他就到了第j个位置。dp[i] == dp[j]

从后先前dp,对于每个以计算的dp。有没有飞行路线能够到达这个点,假设有那么那个点的dp也就计算出了

 

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
struct node{
    int u , v ;
    int next ;
}p[2000];
int head[100000] , cnt ;
double dp[110000] , k[7];
void add(int u,int v)
{
    p[cnt].u = u ;
    p[cnt].v = v ;
    p[cnt].next = head[v] ;
    head[v] = cnt++ ;
}
int main()
{
    int n , m , i , j , l , u , v ;
    for(i = 1 ; i <= 6 ; i++)
        k[i] = 1.0/6 ;
    while(scanf("%d %d", &n, &m) && n+m != 0)
    {
        memset(head,-1,sizeof(head));
        for(i = 0 ; i < n ; i++)
            dp[i] = -1;
        cnt = 0 ;
        while(m--)
        {
            scanf("%d %d", &u, &v);
            add(u,v);
        }
        for(i = n ; i <= n+6 ; i++)
            dp[i] = 0 ;
        for(l = head[n] ; l != -1 ; l = p[l].next)
            dp[ p[l].u ] = dp[n] ;
        for(i = n-1 ; i >= 0 ; i--)
        {
            if( dp[i] != -1 )
            {
                for(l = head[i] ; l != -1 ; l = p[l].next)
                    dp[ p[l].u ] = dp[i] ;
                continue ;
            }
            dp[i] = 1 ;
            for(j = 1 ; j <= 6 ; j++)
                dp[i] += k[j]*dp[i+j] ;
            for(l = head[i] ; l != -1 ; l = p[l].next)
                dp[ p[l].u ] = dp[i] ;
        }
        printf("%.4lf\n", dp[0]);
    }
    return 0;
}


 

posted @ 2017-06-22 15:41  brucemengbm  阅读(244)  评论(0编辑  收藏  举报