hdu 4287 Intelligent IME

Intelligent IME

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3487    Accepted Submission(s): 1659


Problem Description
  We all use cell phone today. And we must be familiar with the intelligent English input method on the cell phone. To be specific, the number buttons may correspond to some English letters respectively, as shown below:
  2 : a, b, c    3 : d, e, f    4 : g, h, i    5 : j, k, l    6 : m, n, o    
  7 : p, q, r, s  8 : t, u, v    9 : w, x, y, z
  When we want to input the word “wing”, we press the button 9, 4, 6, 4, then the input method will choose from an embedded dictionary, all words matching the input number sequence, such as “wing”, “whoi”, “zhog”. Here comes our question, given a dictionary, how many words in it match some input number sequences?


 

Input
  First is an integer T, indicating the number of test cases. Then T block follows, each of which is formatted like this:
  Two integer N (1 <= N <= 5000), M (1 <= M <= 5000), indicating the number of input number sequences and the number of words in the dictionary, respectively. Then comes N lines, each line contains a number sequence, consisting of no more than 6 digits. Then comes M lines, each line contains a letter string, consisting of no more than 6 lower letters. It is guaranteed that there are neither duplicated number sequences nor duplicated words.
 

Output
  For each input block, output N integers, indicating how many words in the dictionary match the corresponding number sequence, each integer per line.
 

Sample Input
1 3 5 46 64448 74 go in night might gn
 

Sample Output
3 2 0
 

Source
 

题目大意:手机键盘中与数字2相相应的字母有a,b,c;3相相应的字母有d。e,f。给出一些数字串如34。和一些小写字母串。求小写字母相应的数字串出现的次数。字符串abc相应的数字串是111,dh相应的数字串是34。

则小写字符串中111出现一次,34出现一次。

题解:由于字符串最长为6。所以直接翻译所给的字符串,记录翻译值得个数再查询就可以。

#include<cstring>
#include<algorithm>
#include<iostream>
#include<cstdio>
#define N 5005

using namespace std;

int n,m;
int a[140];
int b[N];

void init() {
    int x=2;
    for(int i='a'; i<='o'; i+=3) {
        for(int j=i; j<i+3; j++)
            a[j]=x;
        x++;
    }
    a['p']=a['q']=a['r']=a['s']=7;
    a['t']=a['u']=a['v']=8;
    a['w']=a['x']=a['y']=a['z']=9;
}
int num[1000100];

int main() {
   // freopen("test.in","r",stdin);
    int t;
    init();
    cin>>t;
    while(t--) {
        scanf("%d%d",&n,&m);
        for(int i=0; i<n; i++)scanf("%d",&b[i]);
        memset(num,0,sizeof(num));
        while(m--) {
            char s[20];
            scanf("%s",s);
            int sum=0;
            for(int i=0; s[i]; i++)
                sum=sum*10+a[s[i]];
            num[sum]++;
        }
        for(int i=0; i<n; i++) {
            printf("%d\n",num[b[i]]);
        }
    }
    return 0;
}


posted @ 2017-05-24 17:07  brucemengbm  阅读(215)  评论(0编辑  收藏  举报