01-复杂度2 Maximum Subsequence Sum

01-复杂度2 Maximum Subsequence Sum (25 分)

Given a sequence of K integers { N1​, N2​, ..., NK​ }. A continuous subsequence is defined to be { Ni​, Ni+1​, ..., Nj​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.
Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.
Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.
Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21
结尾无空行

Sample Output:

10 1 4
结尾无空行

#include<stdio.h>
int main()
{
    int n;
    scanf("%d",&n);
    int a[n],b[2]={0};
    int i,j;
    for(i=0;i<n;i++)
    {
        scanf("%d",&a[i]);
    }
    int sum=0,maxsum=-10000;
    for(i=0;i<n;i++)
    {
        sum=0;
        for(j=i;j<n;j++)
        {
            sum+=a[j];
            if(sum>maxsum){maxsum=sum;b[0]=a[i];b[1]=a[j];}
        }
    }
    if(b[1]<0){b[1]=a[n-1];b[0]=a[0];maxsum=0;}//全是负数
    printf("%d %d %d",maxsum,b[0],b[1]);
    }

posted @ 2021-08-15 22:01  日月既往、不复可追。  阅读(35)  评论(0编辑  收藏  举报
Fork me on GitHub /*音乐*/ 1 2 3
4