bzoj : 1738: [Usaco2005 mar]Ombrophobic Bovines 发抖的牛 二分 + 网络流 + Floyd

1738: [Usaco2005 mar]Ombrophobic Bovines 发抖的牛

Description

FJ's cows really hate getting wet so much that the mere thought of getting caught in the rain makes them shake in their hooves. They have decided to put a rain siren on the farm to let them know when rain is approaching. They intend to create a rain evacuation plan so that all the cows can get to shelter before the rain begins. Weather forecasting is not always correct, though. In order to minimize false alarms, they want to sound the siren as late as possible while still giving enough time for all the cows to get to some shelter. The farm has F (1 <= F <= 200) fields on which the cows graze. A set of P (1 <= P <= 1500) paths connects them. The paths are wide, so that any number of cows can traverse a path in either direction. Some of the farm's fields have rain shelters under which the cows can shield themselves. These shelters are of limited size, so a single shelter might not be able to hold all the cows. Fields are small compared to the paths and require no time for cows to traverse. Compute the minimum amount of time before rain starts that the siren must be sounded so that every cow can get to some shelter.

    约翰的牛们非常害怕淋雨,那会使他们瑟瑟发抖.他们打算安装一个下雨报警器,并且安排了一个撤退计划.他们需要计算最少的让所有牛进入雨棚的时间.    牛们在农场的F(1≤F≤200)个田地上吃草.有P(1≤P≤1500)条双向路连接着这些田地.路很宽,无限量的牛可以通过.田地上有雨棚,雨棚有一定的容量,牛们可以瞬间从这块田地进入这块田地上的雨棚    请计算最少的时间,让每只牛都进入雨棚.

Input

* Line 1: Two space-separated integers: F and P

 * Lines 2..F+1: Two space-separated integers that describe a field. The first integer (range: 0..1000) is the number of cows in that field. The second integer (range: 0..1000) is the number of cows the shelter in that field can hold. Line i+1 describes field i. * Lines F+2..F+P+1: Three space-separated integers that describe a path. The first and second integers (both range 1..F) tell the fields connected by the path. The third integer (range: 1..1,000,000,000) is how long any cow takes to traverse it.

    第1行:两个整数F和P;
    第2到F+1行:第i+l行有两个整数描述第i个田地,第一个表示田地上的牛数,第二个表示田地上的雨棚容量.两个整数都在0和1000之间.
    第F+2到F+P+I行:每行三个整数描述一条路,分别是起点终点,及通过这条路所需的时间(在1和10^9之间).

Output

* Line 1: The minimum amount of time required for all cows to get under a shelter, presuming they plan their routes optimally. If it not possible for the all the cows to get under a shelter, output "-1".

    一个整数,表示最少的时间.如果无法使牛们全部进入雨棚,输出-1.

Sample Input

3 4
7 2
0 4
2 6
1 2 40
3 2 70
2 3 90
1 3 120

Sample Output

110

思路:

 我们先做一次最短路, 再二分, 对于每个mid ,我们只能连比它段的边, 从s到点连流量为牛数量的边, 从点到点连inf 从点到t连牛棚容量,  判断是否满流即可。

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cctype>
#define ll long long
#define GG puts("Fuck!")
using namespace std;
const int N = 210;
const int inf = 0x3f3f3f3f;
const int M = 210000;
ll f[N][N];
int n1[N], n2[N];
int sum1, sum2;
inline char Nc() {
	static char Buf[100000], *p1, *p2;
	return p1==p2&&(p2=(p1=Buf)+fread(Buf, 1, 100000, stdin), p1==p2)?EOF:*p1++;
}
int Rd() {
	int x = 0;char c = Nc();
	while(!isdigit(c)) c=Nc();
	while(isdigit(c)) x=(x<<1)+(x<<3)+(c^48),c=Nc();
	return x;
}
/*struct Edge {
	int to, val;
	Edge *next;
}*h[N], e[N<<1];*/
int head[N<<2], to[M], val[M], nxt[M], cnt=1;
int _, n, m, s, t;
void Add_Edge(int a,int b,int c) {
    to[++cnt] = b;
    nxt[cnt] = head[a];
    head[a]   = cnt;
    val[cnt]  = c;
    
    to[++cnt] = a;
    nxt[cnt] = head[b];
    head[b]   = cnt;
    val[cnt]  = 0;
}
void floyd() {
	for(int k=1;k<=n;k++) {
		for(int i=1;i<=n;i++) {
			for(int j=1;j<=n;j++) {
				f[i][j] = min(f[i][j], f[i][k] + f[k][j]);
			}
		}
	}
}
#include <queue>
int dep[N<<2];
queue<int>q;
bool bfs() {
    memset(dep,0,sizeof(dep));
    while(!q.empty())q.pop();
    q.push(s);
    dep[s]=1;
    while(!q.empty()) {
        int u=q.front();
        q.pop();
        for(int i=head[u];i;i=nxt[i]) {
            if(!dep[to[i]]&&val[i]) {
                dep[to[i]]=dep[u]+1;
                q.push(to[i]);
            }
        }
    }
    return dep[t]!=0;
}
int dfs(int p,int mf) {
    int nf=0;
    if(p==t)return mf;
    for(int i=head[p];i;i=nxt[i]) {
        if(dep[to[i]]==dep[p]+1&&val[i]) {
            int tmp=dfs(to[i],min(mf-nf,val[i]));
            if(!tmp)dep[to[i]]=0;
            nf+=tmp;
            val[i]-=tmp;
            val[i^1]+=tmp;
            if(nf==mf)break;
        }
    }
    return nf;
}
int dinic() {
    int ans=0;
    while(bfs()) {
        ans+=dfs(s,inf);
    }
    return ans;
}
int main() {
	memset(f, 0x3f, sizeof(f));
	scanf("%d%d", &n, &m);
	for(int i=1;i<=n;i++) n1[i] = Rd(), n2[i] = Rd(), sum1+=n1[i], sum2+=n2[i];
	if(sum1>sum2) {
		puts("-1");return 0;
	}
	for(int i=1;i<=m;i++) {
		int fr= Rd(), ed= Rd(); ll va= Rd();
		f[fr][ed] = min(f[fr][ed], va);
		f[ed][fr] = min(f[fr][ed], va);
	}
	floyd();
	ll l = 0, r = 2e11;
	while(l < r) {
		ll mid = (l+r) >> 1;
		memset(head, 0, sizeof(head));
		cnt=1;
		/*GG;
		printf("%d\n", mid);*/
		for(int i=1;i<=n;i++) {
			for(int j=1;j<=n;j++) {
				if(f[i][j]<=mid||i==j) {
					Add_Edge(i, j+n, inf);
				}
			}
		}
		s = n*2 + 1; t = s+1;
		for(int i=1;i<=n;i++) {
			Add_Edge(s, i, n1[i]);
			Add_Edge(i+n, t, n2[i]);
		}
		if(dinic()==sum1) r = mid;
		else l = mid+1;
	}
	printf("%lld\n", l < (ll)2e11?l:-1);
}

 

posted @ 2018-06-30 16:22  TOBICHI_ORIGAMI  阅读(80)  评论(0编辑  收藏  举报