BZOJ 1741: [Usaco2005 nov]Asteroids 穿越小行星群

1741: [Usaco2005 nov]Asteroids 穿越小行星群

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot. This weapon is quite expensive, so she wishes to use it sparingly. Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

贝茜想驾驶她的飞船穿过危险的小行星群.小行星群是一个NxN的网格(1≤N≤500),在网格内有K个小行星(1≤K≤10000). 幸运地是贝茜有一个很强大的武器,一次可以消除所有在一行或一列中的小行星,这种武器很贵,所以她希望尽量地少用.给出所有的小行星的位置,算出贝茜最少需要多少次射击就能消除所有的小行星.

Input

* Line 1: Two integers N and K, separated by a single space.

* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

    第1行:两个整数N和K,用一个空格隔开.
    第2行至K+1行:每一行有两个空格隔开的整数R,C(1≤R,C≤N),分别表示小行星所在的行和列.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

    一个整数表示贝茜需要的最少射击次数,可以消除所有的小行星

Sample Input

3 4
1 1
1 3
2 2
3 2

INPUT DETAILS:

The following diagram represents the data, where "X" is an
asteroid and "." is empty space:
X.X
.X.
.X.

Sample Output

2

OUTPUT DETAILS:

Bessie may fire across row 1 to destroy the asteroids at (1,1) and
(1,3), and then she may fire down column 2 to destroy the asteroids
at (2,2) and (3,2).

思路 :

并没有看题,这种题一般套路嘛, s连行,列连t 有交点的行连列。完全没有分析,读懂题之后直接上了,没考虑正确性什么的

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <queue>
using namespace std;
const int N = 2000;
int s = 1999, t = 1998;
const int M = 50000;
int head[N],to[M],nxt[M],val[M],cnt=1;
int dep[N];
void add(int a,int b,int c) {
    to[++cnt] = b;
    nxt[cnt]  = head[a];
    head[a]   = cnt;
    val[cnt]  = c;

    to[++cnt] = a;
    nxt[cnt]  = head[b];
    head[b]   = cnt;
    val[cnt]  = 0;
}
queue<int>q;
bool bfs() {
    while(!q.empty()) q.pop();
    memset(dep,0,sizeof dep);
    q.push(s);
    dep[s]=1;
    while(!q.empty()) {
        int u = q.front();
        q.pop();
        for(int i=head[u];i;i=nxt[i]) {
            if(!dep[to[i]]&&val[i]) {
                dep[to[i]]=dep[u]+1;
                q.push(to[i]);
                if(to[i]==t)return 1;
            }
        }
    }
    return 0;
}
int dfs(int p,int mf) {
    if(p==t)return mf;
    int nf=0;
    for(int i=head[p];i;i=nxt[i]) {
        if(dep[to[i]]==dep[p]+1&&val[i]) {
            int tmp = dfs(to[i],min(mf-nf,val[i]));
            if(!tmp)dep[to[i]]=0;
            nf+=tmp;
            val[i]-=tmp;
            val[i^1]+=tmp;
            if(mf==nf)break;
        }
    }
    return nf;
}
void dinic() {
    int ans= 0,tmp;
    while(bfs()) {
        while(tmp=dfs(s,0x3f3f3f3f))ans+=tmp;
    }
    printf("%d\n",ans);
}
int main() {
    int n,k;
    scanf("%d%d",&n,&k);
    for(int i=1;i<=n;i++) add(s,i,1),add(i+n,t,1);
    for(int i=1;i<=k;i++) {
        int a,b;
        scanf("%d%d",&a,&b);
        add(a,b+n,1);
    }
    dinic();
}

 

posted @ 2018-06-14 20:04  TOBICHI_ORIGAMI  阅读(70)  评论(0编辑  收藏  举报