BZOJ 1651: [Usaco2006 Feb]Stall Reservations 专用牛棚

1651: [Usaco2006 Feb]Stall Reservations 专用牛棚

>原题链接<

Description

Oh those picky N (1 <= N <= 50,000) cows! They are so picky that each one will only be milked over some precise time interval A..B (1 <= A <= B <= 1,000,000), which includes both times A and B. Obviously, FJ must create a reservation system to determine which stall each cow can be assigned for her milking time. Of course, no cow will share such a private moment with other cows. Help FJ by determining: * The minimum number of stalls required in the barn so that each cow can have her private milking period * An assignment of cows to these stalls over time

有N头牛,每头牛有个喝水时间,这段时间它将专用一个Stall 现在给出每头牛的喝水时间段,问至少要多少个Stall才能满足它们的要求

Input

* Line 1: A single integer, N

* Lines 2..N+1: Line i+1 describes cow i's milking interval with two space-separated integers.

Output

* Line 1: The minimum number of stalls the barn must have.

* Lines 2..N+1: Line i+1 describes the stall to which cow i will be assigned for her milking period.

Sample Input

5
1 10
2 4
3 6
5 8
4 7

Sample Output

4

思路:

  对每次修改差分,对最后差分求前缀和既是原数组,求一个max即可

代码如下

#include <cstdio>
#define max(a,b) ((a)>(b)?(a):(b))
int c[1100000];
int main() {
    int n,i,x,y,m=0,ans=0;
    scanf("%d",&n);
    for(i=1;i<=n;i++) {
        scanf("%d%d",&x,&y);
        m=max(m,y);
        c[x]++;
        c[y+1]--;
    }
    x=0;
    for(i=1;i<=m;i++) {
        x+=c[i];
        ans=max(x,ans);
    }
    printf("%d\n",ans);
}

 欢迎来原博客看看 >原文链接<

posted @ 2018-05-28 20:53  TOBICHI_ORIGAMI  阅读(23)  评论(0编辑  收藏  举报