1015

题目大意:

Problem Description
Give you a number on base ten,you should output it on base two.(0 < n < 1000)
 

 

Input
For each case there is a postive number n on base ten, end of file.
 

 

Output
For each case output a number on base two.
 

 

Sample Input
1 2 3
 

 

Sample Output
1 10 11
十进制转二进制
解题思路:
按照定义,对二求余
代码:
#include <iostream>
using namespace std;
int main()
{
    int a,i;
    int b[100];
    while(cin>>a)
    {
        i=0;
        while(a!=0)
        {
            b[i]=a%2;
            a/=2;
            i++;
        }
        for(i--;i>=0;i--)
            cout<<b[i];
        cout<<endl;
    }
    return 0;
}

 

posted @ 2016-05-19 09:47  Si考者  阅读(143)  评论(0编辑  收藏  举报