【bzoj3011】[Usaco2012 Dec]Running Away From the Barn 可并堆

题目描述

It's milking time at Farmer John's farm, but the cows have all run away! Farmer John needs to round them all up, and needs your help in the search. FJ's farm is a series of N (1 <= N <= 200,000) pastures numbered 1...N connected by N - 1 bidirectional paths. The barn is located at pasture 1, and it is possible to reach any pasture from the barn. FJ's cows were in their pastures this morning, but who knows where they ran to by now. FJ does know that the cows only run away from the barn, and they are too lazy to run a distance of more than L. For every pasture, FJ wants to know how many different pastures cows starting in that pasture could have ended up in. Note: 64-bit integers (int64 in Pascal, long long in C/C++ and long in Java) are needed to store the distance values. 

给出以1号点为根的一棵有根树,问每个点的子树中与它距离小于等于l的点有多少个。

输入

* Line 1: 2 integers, N and L (1 <= N <= 200,000, 1 <= L <= 10^18)

* Lines 2..N: The ith line contains two integers p_i and l_i. p_i (1 <= p_i < i) is the first pasture on the shortest path between pasture i and the barn, and l_i (1 <= l_i <= 10^12) is the length of that path.

输出

* Lines 1..N: One number per line, the number on line i is the number pastures that can be reached from pasture i by taking roads that lead strictly farther away from the barn (pasture 1) whose total length does not exceed L.

样例输入

4 5
1 4
2 3
1 5

样例输出

3
2
1
1


题解

可并堆

题目中描述有误,应为“小于等于l”,这里已更改。

从下至上维护可并堆,保存每个点到根节点的距离,之所以这样做,是因为:

x到x子树中y节点的距离等于1到y的距离减去1到x的距离!

x到x子树中y节点的距离等于1到y的距离减去1到x的距离!

x到x子树中y节点的距离等于1到y的距离减去1到x的距离!

(听说这题要修改?)

然后随便搞一搞就A了。

#include <cstdio>
#include <algorithm>
using namespace std;
typedef long long ll;
int head[200010] , to[200010] , next[200010] , cnt , root[200010] , l[200010] , r[200010] , d[200010] , si[200010];
ll m , len[200010] , v[200010];
void add(int x , int y , ll z)
{
	to[++cnt] = y;
	len[cnt] = z;
	next[cnt] = head[x];
	head[x] = cnt;
}
int merge(int x , int y)
{
	if(!x) return y;
	if(!y) return x;
	if(v[x] < v[y]) swap(x , y);
	r[x] = merge(r[x] , y);
	if(d[l[x]] < d[r[x]]) swap(l[x] , r[x]);
	d[x] = d[r[x]] + 1;
	return x;
}
void dfs(int x)
{
	int i;
	root[x] = x , si[x] = 1;
	for(i = head[x] ; i ; i = next[i])
		v[to[i]] = v[x] + len[i] , dfs(to[i]) , si[x] += si[to[i]] , root[x] = merge(root[x] , root[to[i]]);
	while(v[root[x]] > m + v[x])
		si[x] --  , root[x] = merge(l[root[x]] , r[root[x]]);
}
int main()
{
	int n , i , x;
	ll z;
	scanf("%d%lld" , &n , &m);
	for(i = 2 ; i <= n ; i ++ )
		scanf("%d%lld" , &x , &z) , add(x , i , z);
	d[0] = -1;
	dfs(1);
	for(i = 1 ; i <= n ; i ++ )
		printf("%d\n" , si[i]);
	return 0;
}

 

posted @ 2017-03-10 20:00  GXZlegend  阅读(597)  评论(0编辑  收藏  举报