【bzoj1738】[Usaco2005 mar]Ombrophobic Bovines 发抖的牛 Floyd+二分+网络流最大流

题目描述

FJ's cows really hate getting wet so much that the mere thought of getting caught in the rain makes them shake in their hooves. They have decided to put a rain siren on the farm to let them know when rain is approaching. They intend to create a rain evacuation plan so that all the cows can get to shelter before the rain begins. Weather forecasting is not always correct, though. In order to minimize false alarms, they want to sound the siren as late as possible while still giving enough time for all the cows to get to some shelter. The farm has F (1 <= F <= 200) fields on which the cows graze. A set of P (1 <= P <= 1500) paths connects them. The paths are wide, so that any number of cows can traverse a path in either direction. Some of the farm's fields have rain shelters under which the cows can shield themselves. These shelters are of limited size, so a single shelter might not be able to hold all the cows. Fields are small compared to the paths and require no time for cows to traverse. Compute the minimum amount of time before rain starts that the siren must be sounded so that every cow can get to some shelter.

约翰的牛们非常害怕淋雨,那会使他们瑟瑟发抖.他们打算安装一个下雨报警器,并且安排了一个撤退计划.他们需要计算最少的让所有牛进入雨棚的时间.    牛们在农场的F(1≤F≤200)个田地上吃草.有P(1≤P≤1500)条双向路连接着这些田地.路很宽,无限量的牛可以通过.田地上有雨棚,雨棚有一定的容量,牛们可以瞬间从这块田地进入这块田地上的雨棚    请计算最少的时间,让每只牛都进入雨棚.

输入

* Line 1: Two space-separated integers: F and P

 * Lines 2..F+1: Two space-separated integers that describe a field. The first integer (range: 0..1000) is the number of cows in that field. The second integer (range: 0..1000) is the number of cows the shelter in that field can hold. Line i+1 describes field i. * Lines F+2..F+P+1: Three space-separated integers that describe a path. The first and second integers (both range 1..F) tell the fields connected by the path. The third integer (range: 1..1,000,000,000) is how long any cow takes to traverse it.

    第1行:两个整数F和P;
    第2到F+1行:第i+l行有两个整数描述第i个田地,第一个表示田地上的牛数,第二个表示田地上的雨棚容量.两个整数都在0和1000之间.
    第F+2到F+P+I行:每行三个整数描述一条路,分别是起点终点,及通过这条路所需的时间(在1和10^9之间).

输出

* Line 1: The minimum amount of time required for all cows to get under a shelter, presuming they plan their routes optimally. If it not possible for the all the cows to get under a shelter, output "-1".

一个整数,表示最少的时间.如果无法使牛们全部进入雨棚,输出-1.

样例输入

3 4
7 2
0 4
2 6
1 2 40
3 2 70
2 3 90
1 3 120

样例输出

110


题解

floyd+二分+拆点+网络流

先用floyd求出任意两点之间的距离。

然后二分答案,若i与j之间的距离小于等于mid,则将i与j'(拆出来的点)间连一条容量为正无穷的边。

将源点与每个点间连一条容量为牛数的边,将每个拆出来的点与汇点间连一条容量为牛棚容量的边。

然后跑网络流,判断是否满流即可。

注意图可以是不连通的,所以当ans过大时,说明必须要用到题目中不存在的边,即无论如何都不能满足题意,输出-1。

注意距离要开long long。

#include <cstdio>
#include <cstring>
#include <queue>
#define inf 0x3fffffff
using namespace std;
queue<int> q;
long long dis[201][201];
int a[201] , b[201] , head[403] , to[180000] , val[180000] , next[180000] , cnt , s , t , deep[403];
void add(int x , int y , long long z)
{
    to[++cnt] = y;
    val[cnt] = z;
    next[cnt] = head[x];
    head[x] = cnt;
}
bool bfs()
{
    int x , i;
    while(!q.empty())
        q.pop();
    memset(deep , 0 , sizeof(deep));
    deep[s] = 1;
    q.push(s);
    while(!q.empty())
    {
        x = q.front();
        q.pop();
        for(i = head[x] ; i ; i = next[i])
        {
            if(val[i] && !deep[to[i]])
            {
                deep[to[i]] = deep[x] + 1;
                if(to[i] == t)
                    return 1;
                q.push(to[i]);
            }
        }
    }
    return 0;
}
int dinic(int x , int low)
{
    if(x == t)
        return low;
    int temp = low , i , k;
    for(i = head[x] ; i ; i = next[i])
    {
        if(val[i] && deep[to[i]] == deep[x] + 1)
        {
            k = dinic(to[i] , min(temp , val[i]));
            if(!k) deep[to[i]] = 0;
            val[i] -= k;
            val[i ^ 1] += k;
            if(!(temp -= k)) break;
        }
    }
    return low - temp;
}
bool judge(int n , long long mid , int sum)
{
    memset(head , 0 , sizeof(head));
    memset(to , 0 , sizeof(to));
    memset(val , 0 , sizeof(val));
    memset(next , 0 , sizeof(next));
    cnt = 1;
    int i , j , maxflow = 0;
    for(i = 1 ; i <= n ; i ++ )
    {
        add(s , i , a[i]);
        add(i , s , 0);
        add(i + n , t , b[i]);
        add(t , i + n , 0);
        for(j = 1 ; j <= n ; j ++ )
        {
            if(i == j || dis[i][j] <= mid)
                add(i , j + n , inf) , add(j + n , i , 0);
        }
    }
    while(bfs())
        maxflow += dinic(s , inf);
    return maxflow == sum;
}
int main()
{
    int n , m , i , j , k , x , y , suma = 0 , sumb = 0;
    long long z , l = 0 , r = 0 , mid , ans = -1;
    scanf("%d%d" , &n , &m);
    s = 0 , t = 2 * n + 1;
    for(i = 1 ; i <= n ; i ++ )
        scanf("%d%d" , &a[i] , &b[i]) , suma += a[i] , sumb += b[i];
    memset(dis , 0x3f , sizeof(dis));
    for(i = 1 ; i <= m ; i ++ )
        scanf("%d%d%lld" , &x , &y , &z) , dis[x][y] = dis[y][x] = min(dis[x][y] , z);
    if(suma > sumb)
    {
        printf("-1\n");
        return 0;
    }
    for(k = 1 ; k <= n ; k ++ )
        for(i = 1 ; i <= n ; i ++ )
            for(j = 1 ; j <= n ; j ++ )
                dis[i][j] = min(dis[i][j] , dis[i][k] + dis[k][j]);
    for(i = 1 ; i <= n ; i ++ )
        for(j = 1 ; j <= n ; j ++ )
            if(i != j)
                r = max(r , dis[i][j]);
    while(l <= r)
    {
        mid = (l + r) >> 1;
        if(judge(n , mid , suma))
            ans = mid , r = mid - 1;
        else
            l = mid + 1;
    }
    printf("%lld\n" , ans < 10000000000000ll ? ans : -1);
    return 0;
}
posted @ 2017-02-13 16:28  GXZlegend  阅读(385)  评论(0编辑  收藏  举报