【bzoj1688】[USACO2005 Open]Disease Manangement 疾病管理 状态压缩dp+背包dp

题目描述

Alas! A set of D (1 <= D <= 15) diseases (numbered 1..D) is running through the farm. Farmer John would like to milk as many of his N (1 <= N <= 1,000) cows as possible. If the milked cows carry more than K (1 <= K <= D) different diseases among them, then the milk will be too contaminated and will have to be discarded in its entirety. Please help determine the largest number of cows FJ can milk without having to discard the milk.

输入

* Line 1: Three space-separated integers: N, D, and K * Lines 2..N+1: Line i+1 describes the diseases of cow i with a list of 1 or more space-separated integers. The first integer, d_i, is the count of cow i's diseases; the next d_i integers enumerate the actual diseases. Of course, the list is empty if d_i is 0. 有N头牛,它们可能患有D种病,现在从这些牛中选出若干头来,但选出来的牛患病的集合中不过超过K种病.

输出

* Line 1: M, the maximum number of cows which can be milked.

样例输入

6 3 2
0---------第一头牛患0种病
1 1------第二头牛患一种病,为第一种病.
1 2
1 3
2 2 1
2 2 1

样例输出

5


题解

状态压缩dp+背包dp

f[i]表示i状态时

不预处理num数组应该也行,尽管常数大些,反正都是一道水题

#include <cstdio>
#include <algorithm>
using namespace std;
int f[32770] , num[32770];
int main()
{
    int n , d , k , i , j , x , y , ans = 0 , s;
    scanf("%d%d%d" , &n , &d , &k);
    for(i = 1 ; i < (1 << d) ; i ++ )
    {
        num[i] = num[i - (i & (-i))] + 1;
    }
    for(i = 1 ; i <= n ; i ++ )
    {
        s = 0;
        scanf("%d" , &x);
        while(x -- )
        {
            scanf("%d" , &y);
            s |= 1 << (y - 1);
        }
        for(j = (1 << d) - 1 ; j >= 0 ; j -- )
        {
            if(num[j | s] <= k)
            {
                f[j | s] = max(f[j | s] , f[j] + 1);
                ans = max(ans , f[j | s]);
            }
        }
    }
    printf("%d\n" , ans);
    return 0;
}
posted @ 2016-12-21 20:46  GXZlegend  阅读(441)  评论(0编辑  收藏  举报