博客园 首页 私信博主 显示目录 隐藏目录 管理 动画

bzoj:1621 [Usaco2008 Open]Roads Around The Farm分岔路口

Description

    约翰的N(1≤N≤1,000,000,000)只奶牛要出发去探索牧场四周的土地.她们将沿着一条路走,一直走到三岔路口(可以认为所有的路口都是这样的).这时候,这一群奶牛可能会分成两群,分别沿着接下来的两条路继续走.如果她们再次走到三岔路口,那么仍有可能继续分裂成两群继续走.    奶牛的分裂方式十分古怪:如果这一群奶牛可以精确地分成两部分,这两部分的牛数恰好相差K(1≤K≤1000),那么在三岔路口牛群就会分裂.否则,牛群不会分裂,她们都将在这里待下去,平静地吃草.    请计算,最终将会有多少群奶牛在平静地吃草.

Input

   两个整数N和K.

Output

    最后的牛群数.

Sample Input

6 2

INPUT DETAILS:

There are 6 cows and the difference in group sizes is 2.

Sample Output

3

OUTPUT DETAILS:

There are 3 final groups (with 2, 1, and 3 cows in them).

6
/ \
2 4
/ \
1 3
 
直接暴力递归上啊,反正0MS
Pascal大法好,瞬间刷上#4
不过前面88KB是怎么做到的……
#include<cstdio>
using namespace std;
int n,m;
int a(int n){
    if (n>m&&(n-m)%2==0) return a((n-m)/2)+a((n+m)/2);return 1;
}
int main(){
    scanf("%d%d",&n,&m);
    printf("%d\n",a(n));
}
var n,m:longint;
function f(n:longint):longint
begin
if (n>m)and((n-m) mod 2=0) then exit(f((n-m) div 2)+f((n+m) div 2));exit(1);
end;
begin
read(n,m);
write(f(n));
end.
posted @ 2015-11-24 19:53  swm_sxt  阅读(206)  评论(0编辑  收藏  举报