十二周作业

本周作业头:

这个作业属于哪个课程 C语言程序设计Ⅱ
这个作业的要求在哪里 https://edu.cnblogs.com/campus/zswxy/software-engineering-class1-2018/homework/2825
我在这个课程的目标 链表的理解
这个作业在那个具体方面帮助我实现目标 删除单链表偶数节点

基础作业

返回
6-1 计算最长的字符串长度 (15 分)
本题要求实现一个函数,用于计算有n个元素的指针数组s中最长的字符串的长度。

函数接口定义:
int max_len( char *s[], int n );
其中n个字符串存储在s[]中,函数max_len应返回其中最长字符串的长度。

裁判测试程序样例:

#include <stdio.h>
#include <string.h>
#include <stdlib.h>

#define MAXN 10
#define MAXS 20

int max_len( char *s[], int n );

int main()
{
    int i, n;
    char *string[MAXN] = {NULL};

    scanf("%d", &n);
    for(i = 0; i < n; i++) {
        string[i] = (char *)malloc(sizeof(char)*MAXS);
        scanf("%s", string[i]);
    }
    printf("%d\n", max_len(string, n));

    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

4
blue
yellow
red
green

输出样例:

6

实验代码:

int max_len( char *s[], int n )
{
    int j,k;
    k=strlen(s[0]);
    for(j=0;j<n;j++){
        if(strlen(s[j])>k)
        k=strlen(s[j]);
    }
    return k;
}

运行结果图:

基础题
剩余时间: --:--:--
返回
6-2 统计专业人数 (15 分)
本题要求实现一个函数,统计学生学号链表中专业为计算机的学生人数。链表结点定义如下:

struct ListNode {
char code[8];
struct ListNode *next;
};
这里学生的学号共7位数字,其中第2、3位是专业编号。计算机专业的编号为02。

函数接口定义:
int countcs( struct ListNode *head );
其中head是用户传入的学生学号链表的头指针;函数countcs统计并返回head链表中专业为计算机的学生人数。

裁判测试程序样例:

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

struct ListNode {
    char code[8];
    struct ListNode *next;
};

struct ListNode *createlist(); /*裁判实现,细节不表*/
int countcs( struct ListNode *head );

int main()
{
    struct ListNode  *head;

    head = createlist();
    printf("%d\n", countcs(head));
	
    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

1021202
2022310
8102134
1030912
3110203
4021205
#

输出样例:
3
实验代码:

int countcs( struct ListNode *head )
{
    int t=0;
    struct ListNode *p;

    for(p=head;p!=NULL;p=p->next)
        if(p->code[1]=='0'&&p->code[2]=='2')
        t++;

    return t;
}

运行结果图:

6-3 删除单链表偶数节点 (20 分)
本题要求实现两个函数,分别将读入的数据存储为单链表、将链表中偶数值的结点删除。链表结点定义如下:

struct ListNode {
int data;
struct ListNode *next;
};
函数接口定义:
struct ListNode *createlist();
struct ListNode *deleteeven( struct ListNode *head );
函数createlist从标准输入读入一系列正整数,按照读入顺序建立单链表。当读到−1时表示输入结束,函数应返回指向单链表头结点的指针。

函数deleteeven将单链表head中偶数值的结点删除,返回结果链表的头指针。

裁判测试程序样例:

#include <stdio.h>
#include <stdlib.h>

struct ListNode {
    int data;
    struct ListNode *next;
};

struct ListNode *createlist();
struct ListNode *deleteeven( struct ListNode *head );
void printlist( struct ListNode *head )
{
     struct ListNode *p = head;
     while (p) {
           printf("%d ", p->data);
           p = p->next;
     }
     printf("\n");
}

int main()
{
    struct ListNode *head;

    head = createlist();
    head = deleteeven(head);
    printlist(head);

    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

1 2 2 3 4 5 6 7 -1

输出样例:

1 3 5 7 

实验代码:

struct ListNode *createlist()
{
    struct ListNode *head,*p,*p1;
    int data;
    head=(struct ListNode*)malloc(sizeof(struct ListNode));

    head->next=NULL;
    p1=head;

    while(1)
    {
       p=(struct ListNode*)malloc(sizeof(struct ListNode));
        scanf("%d",&data);
        if(data==-1)
            break;
        p->data=data;
        p->next=NULL;
        p1->next=p;
        p1=p;
    }
    return head;
};

struct ListNode *deleteeven( struct ListNode *head )
{
    struct ListNode *p1,*p2;

    while(head!=NULL&&head->data%2==0)
    {
        p2=head;
        head=head->next;
        free(p2);
    }
   p1 = head;
    while(p1!=NULL){
        while(p1->next && p1->next->data%2==0){
            p2= p1->next;
            p1->next = p2->next;
        }
        p1= p1->next;
    }
    return head;
}

运行结果图:

学习进度条

周/日期 这周所花时间 学习到的知识点 目前比较迷惑的
3/4-3/9 3小时 文件的读写 文件打开的代码格式
3/9-3/15 4小时 数组的运用 二位数组子数组的最大值的求和
3/16-3/22 3小时 选择排序法 冒泡排序法
3/22-3/29 5小时 二维数组 二维数组与字符串的结合使用
3/29-4/5 4小时 指针与地址 指针与数组的运用
4/5-4/12 6小时 冒泡排序
4/12-4/19 8小时 字符串 内存动态分配
4/19-4/26 5小时 结构 结构指针
4.1-5.10 3小时 汉诺塔 递归
5.10-5.17 10小时 函数指针 链表
posted @ 2019-05-17 20:24  LUcKy_wA  阅读(99)  评论(1编辑  收藏  举报