hdu2458:Kindergarten (最大独立集)

https://vjudge.net/problem/HDU-2458

In a kindergarten, there are a lot of kids. All girls of the kids know each other and all boys also know each other. In addition to that, some girls and boys know each other. Now the teachers want to pick some kids to play a game, which need that all players know each other. You are to help to find maximum number of kids the teacher can pick.

Input

The input consists of multiple test cases. Each test case starts with a line containing three integers
G, B (1 ≤ G, B ≤ 200) and M (0 ≤ M ≤ G × B), which is the number of girls, the number of boys and
the number of pairs of girl and boy who know each other, respectively.
Each of the following M lines contains two integers X and Y (1 ≤ X≤ G,1 ≤ Y ≤ B), which indicates that girl X and boy Y know each other.
The girls are numbered from 1 to G and the boys are numbered from 1 to B.

The last test case is followed by a line containing three zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) followed by a integer which is the maximum number of kids the teacher can pick.

Sample Input

2 3 3
1 1
1 2
2 3
2 3 5
1 1
1 2
2 1
2 2
2 3
0 0 0

Sample Output

Case 1: 3
Case 2: 4

题意分析:

幼儿园里有男孩和女孩, 男孩之间互相认识,认识部分女孩, 女孩之间互相认识,认识部分男孩,给出男孩和女孩之间的认识情况,找出一个集合,里面的人两两认识。

解题思路:

把不认识的人之间连一条线,去掉这些关系后,所有人都是认识的了,即求最大独立集。

#include <stdio.h>
#include <string.h>
#define N 550
int e[N][N], pre[N], n, m;
bool book[N];
int dfs(int u)
{
	for (int i = 1; i <= m; i++)
	{
		if (e[u][i] == 0 && book[i] == false)
		{
			book[i] = true;
			if (pre[i] == -1 || dfs(pre[i]))
			{
				pre[i]=u;
				return 1;
			}
		}
	}
	return 0;
}
int main()
{
	int t=0, i, q, u, v;
	while (scanf("%d%d%d", &n, &m, &q) != EOF)
	{
		if (n == 0 && m == 0 && q == 0)
			break;
		memset(e, 0, sizeof(e));
		while (q--)
		{
			scanf("%d%d", &u, &v);
			e[u][v] = 1;
		}
		int sum = 0;
		memset(pre, -1, sizeof(pre));
		for (i = 1; i <= n; i++)
		{
			memset(book, false, sizeof(book));
			if (dfs(i))
				sum++;
		}
		printf("Case %d: %d\n", ++t, n + m - sum);
	}
	return 0;
}

 

posted @ 2019-07-24 17:47  宿星  阅读(95)  评论(0编辑  收藏  举报