POJ 1222 EXTENDED LIGHTS OUT 高斯消元

EXTENDED LIGHTS OUT
 

Description

In an extended version of the game Lights Out, is a puzzle with 5 rows of 6 buttons each (the actual puzzle has 5 rows of 5 buttons each). Each button has a light. When a button is pressed, that button and each of its (up to four) neighbors above, below, right and left, has the state of its light reversed. (If on, the light is turned off; if off, the light is turned on.) Buttons in the corners change the state of 3 buttons; buttons on an edge change the state of 4 buttons and other buttons change the state of 5. For example, if the buttons marked X on the left below were to be pressed,the display would change to the image on the right. 

The aim of the game is, starting from any initial set of lights on in the display, to press buttons to get the display to a state where all lights are off. When adjacent buttons are pressed, the action of one button can undo the effect of another. For instance, in the display below, pressing buttons marked X in the left display results in the right display.Note that the buttons in row 2 column 3 and row 2 column 5 both change the state of the button in row 2 column 4,so that, in the end, its state is unchanged. 

Note: 
1. It does not matter what order the buttons are pressed. 
2. If a button is pressed a second time, it exactly cancels the effect of the first press, so no button ever need be pressed more than once. 
3. As illustrated in the second diagram, all the lights in the first row may be turned off, by pressing the corresponding buttons in the second row. By repeating this process in each row, all the lights in the first 
four rows may be turned out. Similarly, by pressing buttons in columns 2, 3 ?, all lights in the first 5 columns may be turned off. 
Write a program to solve the puzzle.

Input

The first line of the input is a positive integer n which is the number of puzzles that follow. Each puzzle will be five lines, each of which has six 0 or 1 separated by one or more spaces. A 0 indicates that the light is off, while a 1 indicates that the light is on initially.

Output

For each puzzle, the output consists of a line with the string: "PUZZLE #m", where m is the index of the puzzle in the input file. Following that line, is a puzzle-like display (in the same format as the input) . In this case, 1's indicate buttons that must be pressed to solve the puzzle, while 0 indicate buttons, which are not pressed. There should be exactly one space between each 0 or 1 in the output puzzle-like display.

Sample Input

2
0 1 1 0 1 0
1 0 0 1 1 1
0 0 1 0 0 1
1 0 0 1 0 1
0 1 1 1 0 0
0 0 1 0 1 0
1 0 1 0 1 1
0 0 1 0 1 1
1 0 1 1 0 0
0 1 0 1 0 0

Sample Output

PUZZLE #1
1 0 1 0 0 1
1 1 0 1 0 1
0 0 1 0 1 1
1 0 0 1 0 0
0 1 0 0 0 0
PUZZLE #2
1 0 0 1 1 1
1 1 0 0 0 0
0 0 0 1 0 0
1 1 0 1 0 1
1 0 1 1 0 1

题意

  给你5*6的灯矩阵

  用01表示开关状态,

  每按下一个灯的开关,它与他四周的灯的状态改变,

  问怎么操作使得灯全都关闭灭。

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<vector>
using namespace std;

//#pragma comment(linker, "/STACK:102400000,102400000")
#define ls i<<1
#define rs ls | 1
#define mid ((ll+rr)>>1)
#define pii pair<int,int>
#define MP make_pair

typedef long long LL;
const long long INF = 1e18;
const double Pi = acos(-1.0);
const int N = 1e2+10, M = 1e2+11, mod = 1e9+7, inf = 0x3fffffff;

int a[N][N],x[N],free_x[N];
void Gauss(int equ,int var)
{
    int i,j,k;
    int max_r;
    int col;
    int ta,tb;
    int LCM;
    int temp;
    int free_index;
    int num=0;
    for(int i=0;i<=var;i++)
    {
        x[i]=0;
        free_x[i]=0;
    }
    col=0;
    for(k = 0;k < equ && col < var;k++,col++)
    {
        max_r=k;
        for(i=k+1;i<equ;i++)
        {
            if(abs(a[i][col])>abs(a[max_r][col])) max_r=i;
        }
        if(max_r!=k)
        {
            for(j=k;j<var+1;j++) swap(a[k][j],a[max_r][j]);
        }
        if(a[k][col]==0)
        {
            k--;
            free_x[num++]=col;
            continue;
        }
        for(i=k+1;i<equ;i++)
        {
            if(a[i][col]!=0)
            {
                for(j=col;j<var+1;j++)
                {
                    a[i][j] ^= a[k][j];
                }
            }
        }
    }
   /*
    for (i = k; i < equ; i++)
    {
        if (a[i][col] != 0) return -1;
    }
   */
    for(i=var-1;i>=0;i--)
    {
        x[i]=a[i][var];
        for(j=i+1;j<var;j++)
          x[i]^=(a[i][j]&&x[j]);
    }
    for(int i = 0; i < 30; ++i) {
        if(i%6 == 0) printf("\n%d",x[i]);
        else printf(" %d",x[i]);
    }
    printf("\n");
}
int ss[4][2] = {-1,0,0,-1,1,0,0,1};
void init() {
        memset(a,0,sizeof(a));
        for(int i = 0; i < 30; ++i) a[i][i] = 1;
        for(int i = 0; i < 5; ++i){
            for(int j = 0; j < 6; ++j) {
                for(int k = 0; k < 4; ++k) {
                    int ii = i + ss[k][0];
                    int jj = j + ss[k][1];
                    if(ii < 0 || jj <0 || ii >= 5 || jj >= 6) continue;
                    a[(i) * 6 + j][(ii)*6 + jj] = 1;
                }
            }
        }
}
int main() {
        int cas;
        scanf("%d",&cas);
        for(int K = 1; K <= cas; ++K) {
            init();
            for(int i = 0; i < 30; ++i) scanf("%d",&a[i][30]);
            printf("PUZZLE #%d",K);
            Gauss(30,30);
        }
        return 0;
}

 

  

posted @ 2016-09-16 15:59  meekyan  阅读(263)  评论(0编辑  收藏  举报