HDU 5533/ 2015长春区域 G.Dancing Stars on Me 暴力

Dancing Stars on Me


Problem Description

The sky was brushed clean by the wind and the stars were cold in a black sky. What a wonderful night. You observed that, sometimes the stars can form a regular polygon in the sky if we connect them properly. You want to record these moments by your smart camera. Of course, you cannot stay awake all night for capturing. So you decide to write a program running on the smart camera to check whether the stars can form a regular polygon and capture these moments automatically.

Formally, a regular polygon is a convex polygon whose angles are all equal and all its sides have the same length. The area of a regular polygon must be nonzero. We say the stars can form a regular polygon if they are exactly the vertices of some regular polygon. To simplify the problem, we project the sky to a two-dimensional plane here, and you just need to check whether the stars can form a regular polygon in this plane.
 

 

Input
The first line contains a integer T indicating the total number of test cases. Each test case begins with an integer n , denoting the number of stars in the sky. Following n lines, each contains 2 integers xi,yi , describe the coordinates of n stars.

1T300
3n100
10000xi,yi10000
All coordinates are distinct.
 

 

Output
For each test case, please output "`YES`" if the stars can form a regular polygon. Otherwise, output "`NO`" (both without quotes).
 

 

Sample Input
3 3 0 0 1 1 1 0 4 0 0 0 1 1 0 1 1 5 0 0 0 1 0 2 2 2 2 0
 

 

Sample Output
NO YES NO
 
题意:给你n个点(整点),问你这n个点能否组成正n边形
题解:因为是整点,所有只能是正方形,判断就是了
 
///1085422276
#include<bits/stdc++.h>
using namespace std ;
typedef long long ll;
#define mem(a) memset(a,0,sizeof(a))
#define meminf(a) memset(a,127,sizeof(a));

inline ll read()
{
    ll x=0,f=1;char ch=getchar();
    while(ch<'0'||ch>'9'){
        if(ch=='-')f=-1;ch=getchar();
    }
    while(ch>='0'&&ch<='9'){
        x=x*10+ch-'0';ch=getchar();
    }return x*f;
}
//****************************************

const int inf=9999999;
#define maxn 150
struct node
{
    int x;
    int y;
}p[maxn];
int  d[8];
int n,x[maxn],y[maxn];
int  dis(node a,node b)
{
    return (a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y);
}
bool test()
{
    int ans=inf;
    d[0]=dis(p[0],p[1]);
    d[1]=dis(p[1],p[2]);
    d[2]=dis(p[2],p[3]);
    d[3]=dis(p[3],p[0]);
    d[4]=dis(p[0],p[2]);
    d[5]=dis(p[1],p[3]);
    sort(d,d+6);
    if(d[0]==d[1]&&d[1]==d[2]&&d[2]==d[3]&&2*d[3]==d[4]&&d[4]==d[5])
    {
        return 1;
    }
    return 0;
}
int main(){
    int T=read();
    while(T--){
        scanf("%d",&n);
        for(int i=0;i<n;i++){
            scanf("%d%d",&x[i],&y[i]);
        }
        if(n!=4){
            cout<<"NO"<<endl;
        }
        else {
            for(int i=0;i<4;i++){
                node aa;
                aa.x=x[i],aa.y=y[i];
                p[i]=aa;
            }
            if(test())cout<<"YES"<<endl;
            else cout<<"NO"<<endl;
        }
    }
  return 0;
}
代码

 

posted @ 2015-11-19 14:08  meekyan  阅读(339)  评论(0编辑  收藏  举报