POJ1286 Necklace of Beads(Polya定理)

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 9359   Accepted: 3862

Description

Beads of red, blue or green colors are connected together into a circular necklace of n beads ( n < 24 ). If the repetitions that are produced by rotation around the center of the circular necklace or reflection to the axis of symmetry are all neglected, how many different forms of the necklace are there? 

Input

The input has several lines, and each line contains the input data n. 
-1 denotes the end of the input file. 

Output

The output should contain the output data: Number of different forms, in each line correspondent to the input data.

Sample Input

4
5
-1

Sample Output

21
39

Source

 

哈哈我是来骗访问量的。这题和上一题一毛一样

只不过需要把颜色数改为$3$然后换成LLd

上一篇:https://www.cnblogs.com/zwfymqz/p/9294983.html

 

#include<algorithm>
#include<iostream>
#include<cstdio> 
#define int long long 
using namespace std;
int C = 3, N;
int fastpow(int a, int p) {
    int base = 1;
    while(p) {
        if(p & 1) base = base * a;
        a = a * a; p >>= 1;
    }
    return base;
}
main() {
    while(cin >> N) {
        if(N == -1) break;
        if(N <= 0) {printf("0\n"); continue;}
        int ans = 0;
        for(int i = 1; i <= N; i++) ans += fastpow(C, __gcd(i, N));
        if(N & 1) ans = ans + N * fastpow(C, (N + 1) / 2);
        else ans = ans + N / 2  * (fastpow(C, (N + 2) / 2) + fastpow(C, N / 2));
        cout << ans / 2 / N << endl;
    }
}

 

posted @ 2018-07-11 16:21  自为风月马前卒  阅读(466)  评论(0编辑  收藏  举报

Contact with me