Uva1584

Circular Sequence UVA - 1584

Some DNA sequences exist in circular forms as in the following figure, which shows a circular sequence “CGAGTCAGCT”, that is, the last symbol “T” in “CGAGTCAGCT” is connected to the first symbol “C”. We always read a circular sequence in the clockwise direction. Since it is not easy to store a circular sequence in a computer as it is, we decided to store it as a linear sequence. However, there can be many linear sequences that are obtained from a circular sequence by cutting any place of the circular sequence. Hence, we also decided to store the linear sequence that is lexicographically smallest among all linear sequences that can be obtained from a circular sequence. Your task is to find the lexicographically smallest sequence from a given circular sequence. For the example in the figure, the lexicographically smallest sequence is “AGCTCGAGTC”. If there are two or more linear sequences that are lexicographically smallest, you are to find any one of them (in fact, they are the same).
Input
The input consists of T test cases. The number of test cases T is given on the first line of the input file. Each test case takes one line containing a circular sequence that is written as an arbitrary linear sequence. Since the circular sequences are DNA sequences, only four symbols, ‘A’, ‘C’, ‘G’ and ‘T’, are allowed. Each sequence has length at least 2 and at most 100.
Output
Print exactly one line for each test case. The line is to contain the lexicographically smallest sequence for the test case.
Sample Input
2 CGAGTCAGCT CTCC
Sample Output
AGCTCGAGTC CCCT

#include <cstdio>
#include <iostream>
#include <queue>
#include <vector>
#include<string.h>
#include<map>
#include<bits/stdc++.h>
#define LL long long
#define maxn 100100
using namespace std;
bool cmp(char *b,int p,int q)//参数含义:字符数组/第一种排序的起点/第二种排序的起点
{
   int len=strlen(b);
   for(int i=0;i<len;i++)
   {
       if(b[(i+p)%len]!=b[(i+q)%len])
        return b[(i+p)%len]<b[(i+q)%len];
   }return 0;
}
int main()
{
    int n;
    char b[105];
    scanf("%d",&n);
    while(n--)
    {
        scanf("%s",b);
        int len=strlen(b);
        int ans=0;
        for(int i=0;i<len;i++)
        {
            if(cmp(b,i,ans))ans=i;
        }
        for(int i=0;i<len;i++)
            printf("%c",b[(ans+i)%len]);
        printf("\n");
    }
    return 0;
}

题意:

长度为n的环形序列,需要找到从何处开始的环形序列的字典序是最小的。

思路:

就是模拟啦!~

ans中保存的是当前最小字典序的表达方式。遍历每个字符作为开头的可能。

写一个函数cmp用来比较当前最优解与现在遍历到的解谁更小,如果现在遍历到的解更小,则更新最优解ans。

 

posted @ 2019-05-21 13:53  zuiaimiusi  阅读(227)  评论(0编辑  收藏  举报