PAT 甲级 1094 The Largest Generation

https://pintia.cn/problem-sets/994805342720868352/problems/994805372601090048

 

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a family member, K (>) is the number of his/her children, followed by a sequence of two-digit ID's of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:

23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18

Sample Output:

9 4

代码:

#include <bits/stdc++.h>
using namespace std;

int N, M;
int vis[110], num[110];
vector<int> v[110];
int depth = -1;

void dfs(int root, int step) {
    if(v[root].size() == 0) {
        depth = max(depth, step);
    }

    vis[root] = 1;
    num[step] ++;
    for(int i = 0; i < v[root].size(); i ++) {
        if(vis[v[root][i]] == 0) {
            dfs(v[root][i], step + 1);
        }
    }
}

int main() {
    scanf("%d%d", &N, &M);
    memset(vis, 0, sizeof(vis));
    for(int i = 0; i < M; i ++) {
        int id, K, x;
        scanf("%d%d", &id, &K);
        for(int k = 0; k < K; k ++) {
            scanf("%d", &x);
            v[id].push_back(x);
        }
    }

    dfs(1, 1);
    int temp, ans = INT_MIN;
    for(int i = 0; i <= depth; i ++) {
        if(num[i] > ans) {
            ans = num[i];
            temp = i;
        }
    }
    /*for(int i = 1; i <= depth; i ++)
        printf("%d ", num[i]);*/
    printf("%d %d\n", ans, temp);
    //printf("%d\n", depth);
    return 0;
}

  dfs

posted @ 2019-02-17 14:25  丧心病狂工科女  阅读(306)  评论(0编辑  收藏  举报